Главная страница

МИНИСТЕРСТВО ОБРАЗОВАНИЯ РОССИЙСКОЙ ФЕДЕРАЦИИ

Уфимский государственный авиационный технический университет

Кафедра ИНФОРМАТИКИ

Дисциплина

"Организация интерфейса

в человеко-машинных системах"

для специальности
072200 "Моделирование и исследование операций
в организационно-технических системах"

Рабочая программа | Рабочая программа
Конспект лекций | Темы лекций
 | Практические занятия
Лабораторный практикум | Методические указания к лабораторным работам
Вопросы к зачету | Вопросы к зачету
© Тархов С.В., Уфа, каф. Информатики УГАТУ, 2003 г.


Фамилия Имя Отчество

Уфимский государственный авиационный технический университет

PAБOЧAЯ ПPOГPAMMA

по дисциплине: "Организация интерфейса в человеко-машинных системах"

для специальности 072200 "Моделирование и исследование операций в организационно-технических системах"

факультет: ФИРТ, кypc 3, сeмecтp 6

Уфa 2002 г.

Программу составил: к.т.н, доцент Tapxoв C.B.

ВВЕДЕНИЕ

Рабочая программа составлена в соответствии с дополнительными требованиями вузовско-региональной компоненты к обязательному минимуму содержания и уровню подготовки нженеров по специальности 072200 «Организация интерфейса в человеко-машинных системах».

Дисциплина относится к блоку дисциплин специализации.

1. ЦEЛИ И ЗAДAЧИ ДИCЦИПЛИHЫ, EE MECTO B УЧEБHOM ПPOЦECCE

Интенсивная информатизация общества закономерно привела к формулированию новых, более высоких требований, предъявляемых к качеству подготовки специалистов в сфере компьютерных технологий, способных разрабатывать прикладное программное обеспечения для широкого круга непрофессиональных пользователей персональных компьютеров.

Цель дисциплины "Организация взаимодействия в человеко-машинных системах" - обучение студентов проектированию программного интерфейса и изучение современных аппаратных средств, обеспечивающих взаимодействие пользователя с персональным компьютером.

Задачи изучения дисциплины "Организация взаимодействия в человеко-машинных системах":

1) изучение аппаратных и программных средств, предназначенных для организации человеко-машинного взаимодействия;

2) изучение основ компьютерного дизайна, приемов и правил создания программного интерфейса;

3) обучение студентов практическому использованию программных средств, предназначенных для создания интерфейса в прикладном программном обеспечении.

Изучение курса "Организация взаимодействия в человеко-машинных системах" предполагает наличие у студентов знаний в области информатики, полученных при изучения курса "Информатика".

Программа предусматривает: чтение лекций, проведение практических занятий, лабораторных работ, и зачета. Процесс изучения включает использование студентами ПЭВМ IBM PC, работающих под управлением операционной системы Windows.

В результате изучения данного курса студент должен:

1) уметь:

- использовать современные языки программирования высокого уровня для создания программного интерфейса;

2) знать:

- классификацию, основные характеристики, возможности, достоинства и недостатки современного программного обеспечения, позволяющего разрабатывать элементы программного интерфейса;

- знать назначение, конструктивные особенности, принципы работы и основные технические характеристики аппаратных средств, предназначенных для организации человеко-машинного взаимодействия;

3) иметь представление:

- о перспективах развития программных и аппаратных средств, обеспечивающих эффективное взаимодействие в человеко-машинных системах.

2. СОДЕРЖАНИЕ ДИСЦИПЛИНЫ

2.1. Аудиторный и внеаудиторный практикум

2.1.1. Распределение часов по видам учебных занятий и виды отчетности

№№ | Виды отчетности Виды занятий | Количество учебных часов в 6 семестре
1 | Лекции | 42
2 | Практические занятия | 16
3 | Лабораторные работы | 32
 | Всего аудиторных занятий | 90
4 | Самостоятельная работа студентов |
 | Всего за семестр |
5 | Зачет | +

2.2.2. Аудиторные занятия

2.2.2.1. Распределение часов по темам

№№ | Наименование тем | Всего ауд. час. | Лекций | Практ. зан. | Лаб. работ | Самост. работа | Инструм. средство
1. | Введение. Содержание курса. | 2 | 2 |  |  |  |
2. | Основные исторические сведения о развитии аппаратных и программных средств взаимодействия с ЭВМ. | 2 | 2 |  |  |  |
3. | Классификация и обзор современных аппаратных средств взаимодействия с компьютером. | 4 | 4 |  |  | 12 |
4. | Классификация и обзор современных программных средств взаимодействия с компьютером. | 2 | 2 |  |  | 0 |
5. | Компоненты интерфейса при работе с приложениями в МS DOS и их разработка. | 10 | 2 | 4 | 8 | 0 | Приложения MS DOS
6. | Основные компоненты интерфейса при работе с приложениями в МS Windows. | 6 | 2 |  | 4 | 10 | МS Windows
7. | Основы объектно-ориентиро-ванного программирования | 2 | 2 |  |  | 10 |
8. | Объекты, свойства и методы в среде Windows&Office. | 2 | 2 |  |  |  |
9. | Объектно-ориентированное событийное программирование на Visual Basic | 2 | 2 |  |  | 12 |
10. | Интегрированная среда разработки приложений. Основные Положения Visual Basic. | 4 | 2 |  | 4 | 0 | Visual Basic
11. | Язык Visual Basic. | 16 | 8 | 12 | 8 | 20 | Visual Basic
12. | Основные принципы создания интерфейса. | 2 | 2 |  |  | 0 |
13. | Системы управления интерфейсом пользователя. | 2 | 2 |  |  | 0 |
14. | Типовые ошибки, допускаемые при проектировании программного интерфейса. | 4 | 2 |  | 4 | 0 |
15. | Анализ интерфейсов пользовательских приложений для MS Windows | 22 | 2 |  |  | 20 |
16. | Инструментарий создания интерфейса для пользовательских приложений в интегрированной офисном пакете MS Office с использованием VBA. | 6 | 2 |  | 4 | 10 | Visual Basic for Applica-tion
17. | Перспективы развития аппаратных и программных средств организации человеко-машинного взаимодействия. | 2 | 2 |  |  | 0 |
 | Всего | 90 | 42 | 16 | 32 | 62 |

2.2.2.2. Лекции

1. Введение. Содержание курса. Требования к знаниям и умениям обучаемого.

2. Основные исторические сведения о развитии аппаратных и программных средств взаимодействия с ЭВМ.

3. Классификация и обзор современных аппаратных средств взаимодействия с компьютером.

4. Классификация и обзор современных программных средств взаимодействия с компьютером.

5. Компоненты интерфейса при работе с приложениями в МS DOS и их разработка.

6. Основные компоненты интерфейса при работе с приложениями в МS Windows.

7. Основы объектно-ориентиро-ванного программирования

8. Объекты, свойства и методы в среде Windows&Office.

9. Объектно-ориентированное событийное программирование на Visual Basic

10. Язык Visual Basic. Переменные, константы и типы данных.

11. Операторы. Присваивание, ввод-вывод данных, программирование условий, организация циклов.

12. Обработка символьных данных. Графические операторы. Работа с файлами.

13. Пример разработки приложений.

14. Основные принципы создания интерфейса.

15. Системы управления интерфейсом пользователя.

16. Инструментарий создания интерфейса для пользовательских приложений в интегрированной офисном пакете MS Office с использованием VBA.

17. Перспективы развития аппаратных и программных средств организации человеко-машинного взаимодействия.

2.2.2.3. Практические занятия

1. Программирование элементов программного интерфейса для приложения MS DOS, работающих в текстовом режиме с использованием языка программирования Turbo Pascal.

2. Программирование элементов программного интерфейса для приложения MS DOS, работающих в графическом режиме с использованием языка программирования Turbo Pascal.

3. Дизайн форм программного интерфейса для приложений Windows.

4. Составление Программ на языке Visual Basic.

2.2.2.4. Лабораторные работы

5. Разработка программного интерфейса для приложения MS DOS, работающего в текстовом режиме (на примере интерфейса для программы «Калькулятор»)

6. Разработка программного интерфейса для приложения MS DOS, работающего в графическом режиме (на примере интерфейса для программы «Часы»)

7. Анализ компонентов программного интерфейса пользовательских приложений MS DOS и ОС Windows (на примере программ Norton Commander, Turbo Pascal, и инструментов и приложений Windows).

8. Интегрированная среда разработки приложений Visual Basic, основные компоненты, их назначение и технология работы.

9. Разработка компонентов оконного программного интерфейса в интегрированной среде Visual Basic.

10. Разработка интерфейса программы на языке Visual Basic (на примере интерфейса для программы «Калькулятор»).

11. Разработка интерфейса программы на языке Visual Basic (на примере интерфейса для программы «Просмотрщик графических файлов»).

12. Типовые ошибки, допускаемые при проектировании программного интерфейса.

13. Инструментарий создания интерфейса для пользовательских приложений в интегрированной среде визуального объектно-ориентированного программирования Visual Basic.

2.2.3. Внеаудиторные занятия

2.2.3.2. Содержание самостоятельной работы студентов

Изучение элементов языка визуального объектно-ориентированного программирования Visual Basic и Visual Basic for Application.

3. УЧЕБНО-МЕТОДИЧЕСКИЕ МАТЕРИАЛЫ

3.1. Литература

3.1.1. Основная

1. Гук М. Интерфейсы ПК:Справочник.-СПб:ПИТЕР, 1999.-416с.:ил.; 21см.

2. Кроуфорд Ш. Профессиональная работа в WINDOWS 98:Учебный курс/Пер. с англ.Ю.Стоцкого.- СПб:ПИТЕР,1999.-448с.:ил.;24см.

3. Грошев С.В., Коцюбинский А.О. Современный самоучитель профессиональной работы на компьютере: Практическое пособие.-3-е изд.-М.:Триумф, 1999.-368с.:ил.;23см.-(Русские и английские версии программ)

3.1.2. Дополнительная

1. Laura Arlov's «GUI Design for Dummies» («Дизайн Графического Пользовательского Интерфейса для “Чайников” (Резиновых пробок)»). Книга содержит много примеров и является хорошим справочным пособием как для разработчиков, так и для пользователей.

2. «International User Interfaces» ("Международные Пользовательские Интерфейсы"), под редакцией Elisa del Galdo и Jakob Nielsen, - это справочное пособие для разработчиков, специалистов по документации, и программных менеджеров, работающих в области создания и распространения программного обеспечения для международного использования. У книги решительно академический подход, но в то же время ней представлена информация о международном тестировании программ на пользовательскую пригодность, использование изображений и симвология, дизайн под арабские и китайские шрифты, влияние дизайна на приемлемость продукта в культурной среде.

3. Ben Shneiderman's Designing «The User Interface: Strategies for Effective Communication» «Пользовательский Интерфейс: Стратегии для Эффективной Коммуникации») - исчерпывающий учебник, охватывающий историю, вопросы, лежащие в основе предмета, и принципы дизайна пользовательского интерфейса. Предназначена для дизайнеров и разработчиков-программистов.

4. Everett McKay's «Developing User Interfaces for Microsoft Windows» («Разрабатывая Пользовательские Интерфейсы для Microsoft Windows») - содержит большое количество практической, просто изложенной информации, написана специально для разработчиков под Windows.

5. Edward Tufte's «The Visual Display of Quantitative Information» («Визуальное отображение количественной информации») – содержит исчерпывающие рекомендации по представлению данных. Полная примеров, эта книга поможет Вам создать элегантную и профессиональную деловую графику.

6. «Human Factors Design Guide». («Руководство по созданию интерфейса»). Из тысячи страниц одна глава - 150 листов - содержит перечень правил, которые необходимо соблюдать при проектировании пользовательских интерфейсов.

7. Clayton Lewis и John Rieman. «Task-Centered User Interface Design» (Основные задачи проектирования пользовательского интерфейса) - книга содержит массу полезных идей, которые необходимо знать любому программисту, работающему над созданием интерфейсов.

8. Sun Microsystem's «Java Look and Feel Guidelines» ("Руководство по Java и внешнему восприятию») - приведена полезная информация для разработчиков приложений и аплетов на языке программирования JavaTM.

3.2. Использование ЭВМ

При проведении лабораторных работ по дисциплине используются IBM совместимые персональные компьютеры класса Pentium с установленной на них ОС Windows 95 (98), системой программирования Borland Pascal for Windows, математическим пакетом Derive, офисным приложением MS Office, системой проектирования чертежей AutoCad.

3.3. Методические указания по преподаванию дисциплины

При изучении учебной дисциплины предусматривается лекционное изложение курса, работа с учебниками и учебными пособиями, лабораторные работы, а также консультации по изучаемым разделам курса. В связи с сокращением количества лекций часть тем излагается кратко. Студентам рекомендуется обращаться к более полному изложению и примерам, приведенным в основной литературе по учебной дисциплине. Для более полного усвоения материала студентам рекомендуется изучать периодическую литературу соответствующей тематики.

Выполнение лабораторных работ заканчивается составлением отчета с выводами, характеризующими полученный результат. Работа считается полностью выполненной после ее защиты.

При самостоятельной подготовке студенты должны оформлять отчеты о проделанной работе, что учитывается при аттестации студентов по изучаемой дисциплине в конце семестра.

Завершающими этапами изучения дисциплины являются зачет, экзамен, курсовая работа.


Тархов Сергей Владимирович

докторант, кандидат технических наук, доцент,
заместитель заведующего кафедрой информатики
Уфимского государственного авиационного технического университета.

т. (3472) 23-78-76

E-mail: TarkhovSV@soros.bachedu.ru

С 1990 г. преподает дисциплины "Информатика", "Компьютерные технологии", Электронный офис", "Системы подготовки деловой документации", "Организация интерфейса в человеко-машинных системах" и др.

Один из авторов новой инструментально обеспеченной методики преподавания дисциплины “Информатика” и других дисциплин компьютерного профиля для подготовки бакалавров и магистров, внедренной в учебный процесс в ряде вузов региона.

В 1998 году им получен и успешно выполнен грант "Института Открытое общество" (фонд Сороса) "Музей истории отечественных компьютеров", опубликованный http://www.bashedu.ru/konkurs/tarhov/index.htm и размещенный на CD Московского Центра интернет-образования в разделе "Ресурсы Интернета".

Тархов С.В. является автором более 80 научных и методических работ.

Область научный интересов: проектирование информационно-обучающих сред для образовательных систем.

[На главную страницу]


Теоретический материал

Конспект лекций

по дисциплине: "Организация интерфейса в человеко-машинных системах"

Тема 1

Введение. Основные исторические сведения о развитии аппаратных и программных средств взаимодействия с ЭВМ.

Тема 2

Классификация и обзор современных аппаратных средств взаимодействия с компьютером.

Тема 3

Классификация и обзор современных программных средств взаимодействия с компьютером.

Тема 4

Компоненты интерфейса при работе с приложениями в операционных системах МS DOS и Windows.

Тема 5

Основы объектно-ориентированного программирования

Тема 6

Объекты, свойства и методы в среде Windows&Office.

Тема 7

Объектно-ориентированное событийное программирование на Visual Basic

Тема 8

Интегрированная среда разработки приложений. Основные Положения Visual Basic

Тема 9

Язык Visual Basic

Тема 10

Типы интерфейсов, создаваемых в Visual Basic

Тема 11

Проектирование основных компонентов интерфейса в VisualBasic

Тема 12

Основные принципы создания интерфейса.

Тема 13

Рекомендации по разработке интерфейса

Тема 14

Особенности проектирования средств управления графического интерфейса пользователя

Тема 15

Типовые ошибки, допускаемые при проектировании программного интерфейса

Тема 16

Перспективы развития аппаратных и программных средств организации человеко-машинного взаимодействия.


Практическое занятие

Практические занятия

по дисциплине: "Организация интерфейса в человеко-машинных системах"

Занятие № 1

Программирование элементов программного интерфейса для приложения MS DOS, работающих в текстовом режиме с использованием языка программирования Turbo Pascal.

Цель практического занятия: Изучение возможностей разработки компонентов программного интерфейса для приложений ОС MS DOS, работающих в текстовом режиме.

Темы, рассматриваемые на занятии:

  1. Программирование окон
  2. Программирование меню
  3. Организация защиты от неверных действий пользователя

Занятие № 2

Программирование элементов программного интерфейса для приложения MS DOS, работающих в графическом режиме с использованием языка программирования Turbo Pascal.

Цель практического занятия: Изучение возможностей разработки компонентов программного интерфейса для приложений ОС MS DOS, работающих в графическом режиме.

Темы, рассматриваемые на занятии:

Использование процедур и функций модуля Graph языка программирования Turbo Pascal для создания элементов программного интерфейса

Занятие № 3-8

Программирование элементов интерфейса с использованием языка Visual Basic.

Цель практического занятия: Изучение возможностей разработки компонентов программного интерфейса для приложений Windows с использованием языка Visual Basic.

Темы, рассматриваемые на занятии:

  1. Программирование линейных и разветвляющихся структур
  2. Программирование циклических структур
  3. Работа с массивами (таблицами) данных
  4. Работа с файлами
  5. Работа со строками
  6. Работа с графикой


Лабораторный практикум

по дисциплине: "Организация интерфейса в человеко- машинных системах "

Лабораторная работа № 1

Разработка программного интерфейса для приложения MS DOS, работающего в текстовом режиме (на примере интерфейса для программы «Калькулятор»)

Лабораторная работа № 2

Разработка программного интерфейса для приложения MS DOS, работающего в графическом режиме (на примере интерфейса для программы «Часы»)

Лабораторная работа № 3

Анализ компонентов программного интерфейса пользовательских приложений MS DOS и ОС Windows (на примере программ Norton Commander, Turbo Pascal, и инструментов и приложений Windows).

Лабораторная работа № 4

Интегрированная среда разработки приложений Visual Basic, основные компоненты, их назначение и технология работы.

Лабораторная работа № 5

Разработка компонентов оконного программного интерфейса в интегрированной среде Visual Basic.

Лабораторная работа № 6

Разработка интерфейса программы на языке Visual Basic (на примере интерфейса для программы «Калькулятор»).

Лабораторная работа № 7

Разработка интерфейса программы на языке Visual Basic (на примере интерфейса для программы «Просмотрщик графических файлов»).

Лабораторная работа № 8

Типовые ошибки, допускаемые при проектировании программного интерфейса.

Лабораторная работа № 9

Разработка интерфейса программы на языке Visual Basic (на примере интерфейса для программы «Шутка»).


Лабораторная работа № 1

Разработка программного интерфейса для приложения MS DOS, работающего в текстовом режиме (на примере интерфейса для программы «Калькулятор»)

Цель работы: Изучение возможностей разработки компонентов программного интерфейса для приложений ОС MS DOS, работающих в текстовом режиме.

Задачи:

- научиться разрабатывать элементы интерфейса и средства защиты от неверных действий пользователя, используя язык программирования высокого уровня Turbo-Pascal.

- научиться выполнять тестирование программы на предмет проверки работоспособности и корректности работы разработанного программного интерфейса.

Задание на выполнение работы

1. Разработать программу «калькулятор», выполняющую четыре арифметических действия: сложение вычитание, умножение и деление вещественных чисел, содержащую минимально необходимые для использования программы элементы пользовательского интерфейса. Сохранить исходный текст программы и исполнимый файл (.exe) на диске.

2. Разработать элементы программного интерфейса – окно формы, поля для ввода-вывода данных, текстовые подсказки, элементы защиты от неверных действий пользователя, используя процедуры и функции модуля CRT.. Сохранить исходный текст программы и исполнимый файл (.exe) на диске.

3. Выполнить тестирование программы на предмет проверки работоспособности и корректности работы разработанного программного интерфейса и продемонстрировать результаты работы составленных программ преподавателю.

4. Составить отчет о работе, используя текстовый процессор WordPad или MS Word.

Содержание отчета:

- группа и фамилия студента, дата выполнения лабораторной работы,

- фамилия преподавателя, ведущего лабораторный практикум,

- название работы, цель и задачи работы,

- тексты программ - калькулятор с минимальным интерфейсом и с разработанным оконным интерфейсом,

- экранные формы, характеризующие пользовательский интерфейс разработанной программы «калькулятор»,

- содержание тестовых примеров и результаты тестирования разработанной программы «калькулятор»,

- описание программы «калькулятор» и руководство пользователя программой.

Примечание: Для вставки рисунков в текст документа используйте программы снятия копий элементов и областей экранных форм (например программу HyperSnap или графический редактор MS Paint).

Методические рекомендации к выполнению работы

1. Пример работы программы «калькулятор» и вариант текста программы на языке TurboPascal при полном отсутствии какого-либо интерфейса.

var
a,b,c:real; v:char;
begin
readln(a); readln(v); readln(b);
case v of
'+': c:=a+b;
'-': c:=a-b;
'*': c:=a*b;
'/': c:=a/b;
end;
write('=',c:0:8); readln;
end.

2. Примеры реализации интерфейса для программы «калькулятор»

Для ввода чисел (исходных данных для вычисления), знака операции и ввода результата вычисления (ответа) используются разные поля, снабженные подсказками (текстовыми метками в окне формы).

Отдельное поле предназначено для вывода подсказок.
Ввод и вывод данных в виде выражения осуществляется в одном текстовом поле (текстовая строка ввода-вывода данных)

В окне формы приводятся тексты подсказок.

Для ввода чисел (исходных данных для вычисления) и знака операции используются разные поля, снабженные подсказками (текстовыми метками в окне формы).

Для ввода результата вычисления (ответа) используется текстовое поле.

Отдельное поле предназначено для вывода подсказок.

Для ввода чисел, знака операции и вывода результатов вычисления (ответа) используются разные поля.

Отдельное поле предназначено для вывода подсказок.

Рекомендации по созданию элементов интерфейса программы «калькулятор»

Используем в тексте программы следующие переменные:
 ......
const
left = 20; top = 8; right = 56; bottom = 14;
var
.....
str : string; {для ввода значения чисел}
num1,num2 : real; {числа с которыми производятся действия }
result : real; {результат}
action : char; {вид операции (сложение, умножение и т.д.)}
 i, j, k : byte; {вспомогательныеt переменная}
......

For i:=(left + 1) to (right - 1) do {горизонтальные линии}
begin
GotoXY(i,top);
Write(chr(205));
GotoXY(i,bottom);
Write(chr(205));
end;
For j:=(top+1) to (bottom-1) do { вертикальные линии}
begin
GotoXY(right,j);
Write(chr(186));
GotoXY(left,j);
Write(chr(186));
end;
GoToXY(left,top); { углы рамки окна}
Write(chr(201));
GoToXY(right,top);
Write(chr(187));
GoToXY(right,bottom);
Write(chr(188));
GoToXY(left,bottom);
Write(chr(200));
GoToXY(left + 2, top); {надпись разрыве линий рамки}
Write(' Калькулятор '); 		прорисовка рамки окна формы сплошной двойной линией с надписью "Калькулятор" в разрыве линий рамки.
repeat
......
readln(str);
val(str,num1,k);
until k=0; 		цикл, позволяющий ввести только число (исключающий его неправильный ввод)
case action of
.....
'/': if (num2<>0) then result:= num1 / num2
else
begin
.....
write(' Деление на ноль ');
.....
end;
.....
end; 		проверка деления на ноль

3. Примеры тестов для проверки работоспособности и корректности работы разработанного программного интерфейса.

Проверить корректность работы при сложении, вычитании, умножении и делении различных целых и вещественных, положительных и отрицательных чисел, например:
1,2365*(-5) - результат: -6,1825 (результат верный)
0,000025/100 - результат: 0,0000 (результат не верный из-за вывода только 4-х цифр после запятой)
и т.д.

Проверить возможность продолжения вычислений или завершения работы программы

Проверка на ввод неверного символа операции

Другие тесты в зависимости от возможностей разработанного программного интерфейса.

ПРИМЕЧАНИЕ: Программы, разработанные студентами в процессе выполнения лабораторной работы должны иметь оригинальный (отличающийся от других программ) интерфейс. Программы с одинаковым интерфейсом и исходным текстом приниматься в качестве результата лабораторной работы не будут.

4. Пример оформления отчета по лабораторной работе (текст подготовлен в MS Word)


Лабораторная работа № 2

Разработка программного интерфейса для приложения MS DOS, работающего в графическом режиме (на примере интерфейса для программы «Часы»)

Цель работы: Изучение возможностей разработки компонентов программного интерфейса для приложений ОС MS DOS, работающих в графическом режиме.

Задачи:

- научиться работать с элементами интерфейса и средствами защиты от неверных действий пользователя, используя язык программирования высокого уровня Turbo-Pascal.

Задание на выполнение работы

1. Разработать программу «часы» или «таймер», показывающую системное время и выдающую звуковые сигналы в заданное время. Сохранить текст программы на диске.

2. Разработать элементы графического программного интерфейса, используя процедуры и функции модуля Graph. и DOS. Сохранить текст программы на диске.

3. Выполнить тестирование программы на предмет проверки работоспособности и корректности работы разработанного программного интерфейса и продемонстрировать результаты работы составленной программы преподавателю.

4. Составить отчет о работе, используя текстовый процессор WordPad или MS Word (пример оформления отчета см. в лабораторной работе №1).

Содержание отчета:

- группа и фамилия студента, дата выполнения лабораторной работы,

- фамилия преподавателя, ведущего лабораторный практикум,

- название работы, цель и задачи работы,

- тексты программ - «часы» или «таймер»,

- экранные формы, характеризующие пользовательский интерфейс разработанной программы,

- описание программы «калькулятор» и руководство пользователя программой.

Примечание: Для вставки рисунков в текст документа используйте программы снятия копий элементов и областей экранных форм (например программу HyperSnap или графический редактор MS Paint).

Методические рекомендации к выполнению работы

1. Примеры реализации интерфейса для программы «часы»

Стрелочные часы с секундной стрелкой. В нижней части окна выводится текущая дата. Шаг перемещения стрелок: секундной - 1 секунда, большой (минутной) - 1 минута, маленькой (часовой) - 1 час. По мере движения секундной стрелки меняются цвета цифр и делений на циферблате. При достижении секундной стрелки цифры 12 все деления циферблата и цифры на нем окрашиваются в белый цвет.

Стрелочные часы с секундной стрелкой. В пределах циферблата расположены цифровые часы. Шаг перемещения стрелок - плавный.

Часы с нестандартным интерфейсом. Главное окно часов выполнено в форме эллипса. Внутри главного окна расположены: окно для отображения времени (в нижней части в черном прямоугольном окне (число 23) показывается время в часах); окно для отображения даты (слово Сегодня и текущая дата); окно для отображения минут (окружность справа) с индикаторной стрелкой; окно для отображения секунд (окружность слева) с индикаторной стрелкой. Шаг перемещения стрелок: секундной - 1 секунда, минутной - 1 минута. Каждые 30 секунд - звуковой сигнал и изменение цвета рамки главного окна.

2. Рекомендации по написанию программы.

Для определения системной даты и времени используйте процедуры GetDate(g,n,t,gh) и GetTime(h,min,sec,hg) модуля DOS языка программирования TurboPascal.

Пример процедуры для рисования циферблата часов:

Procedure Ciferblat;
Begin
For b:=1 to 60 do
Begin
xS:=Round(140*Cos(((2*pi) / 60)*b-pi/2));
yS:=Round(140*Sin(((2*pi) / 60)*b-pi/2));
xM:=Round(145*Cos(((2*pi) / 60)*b-pi/2));
yM:=Round(145*Sin(((2*pi) / 60)*b-pi/2));
Line(xo+xs,yo+ys,xo+xm,yo+ym);
Line(xo-145,yo,xo-135,yo);Line(xo,yo-145,xo,yo-135);
Line(xo+145,yo,xo+135,yo);Line(xo,yo+145,xo,yo+135);
OutTextXY(xo-130,yo-5,'9');
OutTextXY(xo+120,yo-5,'3');
OutTextXY(xo-5,yo+120,'6');
OutTextXY(xo-12,yo-125,'12');
SetTextStyle(0,0,1);
OutTextXY(xo+63,yo-117,'1');
OutTextXY(xo-68,yo-117,'11');
OutTextXY(xo+63,yo+113,'5');
OutTextXY(xo-67,yo+113,'7');
OutTextXY(xo+110,yo-70,'2');
OutTextXY(xo+113,yo+65,'4');
OutTextXY(xo-115,yo-70,'10');
OutTextXY(xo-115,yo+65,'8');
SetTextStyle(0,0,2);
End;
End;

Пример процедуры, показывающей время на цифровых часах:

Procedure ShowTime;
Begin
Str(Hour,s1);
Str(Minute,s2);
Str(Second,s3);
If Length(s1) <2 then s1:='0'+s1;
If Length(s2) <2 then s2:='0'+s2;
If Length(s3) <2 then s3:='0'+s3;
SetFillStyle(1,black);
Bar(0,0,640,80);
SetColor(Green);
OutTextXY(xo-63,40,s1+':'+s2+':'+s3);
End;

Пример процедуры рисования стрелок часов:

Procedure DoIt;
Begin
rad:=(2*pi) / 60 ; RadH:=(2*pi) / 12 ;
While NOT (Keypressed) do
Begin
GetTime(Hour,Minute,Second,T);
If Second <> S Then
Begin
s:=Second;
SetColor(Black);
Line(xo,yo,xo+xS,yo+yS);
Line(xo,yo,xo+xM,yo+yM);
Line(xo,yo,xo+xH,yo+yH);
xS:=Round(110*Cos(rad*Second-pi/2));
yS:=Round(110*Sin(rad*Second-pi/2));
SetColor(Yellow);
Line(xo,yo,xo+xS,yo+yS);
xM:=Round(80*Cos(rad*Minute-pi/2));
yM:=Round(80*Sin(rad*Minute-pi/2));
SetColor(White);
Line(xo,yo,xo+xM,yo+yM);
If Hour >= 12 then Hour:=Hour-12;
xH:=Round(50*Cos(radH*Hour-pi/2));
yH:=Round(50*Sin(radH*Hour-pi/2));
SetColor(White);
Line(xo,yo,xo+xH,yo+yH);
Circle(xo,yo,1);
Circle(xo,yo,2);
End;
End;
End;

ПРИМЕЧАНИЕ: Программы, разработанные студентами в процессе выполнения лабораторной работы должны иметь оригинальный (отличающийся от других программ) интерфейс. Программы с одинаковым интерфейсом и исходным текстом приниматься в качестве результата лабораторной работы не будут.


Лабораторная работа № 3

Анализ компонентов программного интерфейса пользовательских приложений MS DOS и ОС Windows (на примере программ Norton Commander, Turbo Pascal, и инструментов и приложений Windows).

Цель работы: Изучение особенностей программного интерфейса прикладного программного обеспечения для операционных систем MS DOS и Windows.

Задачи:

- научиться выделять и определять назначение основных типовых компонентов программного интерфейса прикладного программного обеспечения ОС MS DOS.

- научиться выделять и определять назначение основных типовых компонентов программного интерфейса ОС Windows и прикладного программного обеспечения для Windows.

Задание на выполнение работы

1. В соответствии с заданным вариантом ознакомиться с элементами программного интерфейса.

2. Выявить недостатки, имеющиеся в изучаемом программном интерфейсе, описать их и предложить возможные изменения, обосновав их.

3. Составить отчет о работе, используя текстовый процессор WordPad или MS Word.

Содержание отчета:

- группа и фамилия студента, дата выполнения лабораторной работы,

- фамилия преподавателя, ведущего лабораторный практикум,

- название работы, цель и задачи работы,

- описание элементов программных интерфейсов и их экранные формы,

- описание выявленных недостатков, имеющихся в изучаемом программном интерфейсе,

- предложения по возможным изменениям программного интерфейса с обоснованием предлагаемых изменений.

Примечание: Для вставки рисунков в текст документа используйте программы снятия копий элементов и областей экранных форм (например программу HyperSnap или графический редактор MS Paint).

Варианты заданий для выполнения анализа программного интерфейса (названия программ и их компоненты):

1. Norton Commander \ копирование и Windows \ панель управления \ настройка мыши.

2. Norton Commander \ переименование (перемещение) и Windows \ панель управления \ настройка клавиатуры.

3. Norton Commander \ поиск файла и Windows \ панель управления \ настройка языка и стандартов.

4. Norton Commander \ главное и вложенное меню и Windows \ панель управления \ свойства системы.

5. Norton Commander \ создание каталога и Windows \ панель управления \ настройка свойств экрана.

6. Norton Commander \ просмотрщик файлов и Windows \ настройка свойств корзины.

7. Norton Commander \ встроенный редактор файлов и Windows \ настройка свойств панели задач.

8. Norton Commander \ система справки и Windows \ свойства диска.

9. Norton Commander \ сведения о системе и Windows \ установка оборудования.

10. Norton Commander \ свойства экрана и Windows \ установка (удаление) программ.

11. Norton Commander \ поиск директории и Windows \ Paint \макет страницы.

12. Turbo Pascal \ сохранение файла и Windows \ установка принтера.

13. Turbo Pascal \ открытие файла и Windows \ поиск файлов и папок.

14. Turbo Pascal \ замена подстроки и Windows \ система справки.

15. Turbo Pascal \ смена директории и Windows \ настройка сетевого окружения.

16. Turbo Pascal \ настройка параметров компилятора и Windows \ проверка диска.

17. Turbo Pascal \ настройка параметров отладчика программ и Windows \ дефрагментация диска.

18. Turbo Pascal \ главное и вложенное меню и Word \ открытие файла.

19. Turbo Pascal \ окно редактора программ и Word \ настройка параметров.

20. Turbo Pascal \ окно настройки рабочих директорий и Word \ создание стилей.

21. Turbo Pascal \ окно изменения значения переменной в процессе отладки программы и Word \ окно настройки параметров шрифта.

22. Turbo Pascal \ поиск подстроки и Word \ параметры страницы.

Пример фрагмента отчета (без заголовка - группа и фамилия студента, дата выполнения лабораторной работы, фамилия преподавателя, ведущего лабораторный практикум, название работы, цель и задачи работы).


Лабораторная работа № 4

Интегрированная среда разработки приложений Visual Basic, основные компоненты, их назначение и технология работы.

Цель работы: Изучение структуры и основных компонентов среды Visual Basic, позволяющей создавать элементы программного интерфейс приложений операционной системы Windows.

Задачи:

- изучить структуру среды разработки приложений Visual Basic,

- научиться работать с основными компонентами среды Visual Basic.

- разработать проект, содержащий различные компоненты интерфейса.

Задание на выполнение работы

1. Запустить Visual Basic и создать новый проект на основе шаблона

2. Изучить компоненты инструментальной среды проектирования Visual Basic с использованием описания, представленного в электронном виде:
«Интегрированная среда визуального объектно-ориентированного программирования Visual Basic 6.0»

3. Ответить на контрольные вопросы и продемонстрировать полученные навыки работы преподавателю.

4. Отчет о работе представляется в виде файла с разработанным проектом приложения.

Методические указания

После запуска Visual Basic и выбора типа проекта (в нашем случае Standard EXE) изучите компоненты инструментальной среды разработки приложений Visual Basic. Ее внешний вид (после открытия основных окон) показан на рисунке.

Рассмотрите содержание и назначение пунктов меню Visual Basic.

Главное меню (текстовое меню), как и во всех приложениях Microsoft, представляет собой линейку раскрывающихся меню. Оно содержит следующие основные команды: File (Файл), Edit (Правка), View (Вид), Project (Проект), Format (Формат), Debug (Отладка), Run (Запуск), Query (Запрос), Diagram (Диаграмма), Tools (Сервис), Add-Ins (Надстройки), Window (Окно), Help (Справка).

Наиболее часто используемые команды меню отображены в виде кнопок со значками на панели инструментов (пиктографическом меню), размещенной ниже меню.

Основными рабочими элементами среды Visual Basic, с помощью которых выполняется визуальное проектирование приложения являются окно конструктора форм и панель элементов управления.

Окно конструктора форм

В окне конструктора форм визуально конструируются все формы приложения с использованием инструментария среды разработки. Окно конструктора форм открывается автоматически после загрузки среды Visual Basic.

Если окно закрыто, вызвать его можно из главного меню командой Object (Объект) меню View (Вид) или командой View Object контекстного меню объекта, находящегося в группе Forms в проводнике проекта.

Для точного позиционирования объектов в форме в окне имеется сетка. Размер ячеек сетки можно менять. При необходимости сетку можно отключать, воспользовавшись параметрами диалогового окна Options, открываемого командой Options (Параметры) из меню View (Вид).

Размер формы в окне можно изменять, используя маркеры выделения формы и мышь. Для изменения размера формы необходимо установить указатель мыши на маркер и, когда он примет вид двунаправленной стрелки, перемещать до получения требуемого размера.

Панель элементов управления

Панель элементов управления открывается автоматически после загрузки среды Visual Basic. Если панель элементов закрыта, вызывать ее можно из меню View (Вид) командой Toolbox (Панель элементов управления) или воспользоваться кнопкой Toolbox на стандартной панели инструментов.

В составе панели элементов управления содержатся основные элементы (компоненты), размещаемые на форме при ее проектировании — метки, текстовые поля, кнопки, списки и другие элементы для быстрого визуального проектирования макета формы.

Для размещения элементов управления в форме с помощью панели элементов выполните следующие действия:

1. Выделите требуемый элемент управления с помощью мыши.

2. Перейдите в окно конструктора форм. Указатель мыши при этом превратится в крестик, при помощи которого можно установить местоположение размещаемого объекта. Левой кнопкой мыши зафиксируйте позицию нового объекта и, удерживая кнопку, задайте размеры объекта.

Поместить на панель элементов управления компоненты можно используя пункт Components...(Компоненты) контекстного меню, вызываемого правой кнопкой мыши при нахождении курсора на свободной области панели элементов управления. При этом откроется окно выбора компонентов.

Окно выбора компонентов содержит три вкладки:

Controls (Средства управления) - позволяет выбрать компоненты, размещаемые на панели элементов управления. Компоненты хранятся в файлах, имеющих расширение .OCX или в файлах динамических библиотек .DLL. Выбрать файлы можно также вручную, используя кнопку Browse... (Просмотр)

Designers (Проектировщики) - позволяет подключить динамические библиотеки, необходимые для работы создаваемого в среде Visual Basic приложения.

Insertable Objects (Встраиваемые объекты) - позволяет выбрать компоненты, представляющие собой OLE - объекты или программные приложения. Компоненты хранятся в файлах, имеющих расширение .OCX, в файлах динамических библиотек .DLL или в исполняемых файлах .EXE.

Ключ Select Items Only (Только выбранные пункты) позволяет исключить из списка компонентов пункты, не отмеченные ключами выбора.

Разместите на панели элементов управления компоненты Microsoft Windows Commom Controls 6.0.

Создание любого приложения в Visual Basic начинается с создания проекта. Проектом является совокупность файлов, входящих в приложение и хранящих информацию о его компонентах. Проект стандартного приложения создается на основе шаблона Standard EXE.

Большинство приложений, созданных в Visual Basic, работают в интерактивном режиме. На экран выводится информация, предназначенная для пользователя программы, и ожидается его ответная реакция в виде ввода данных или команд. Интерактивное приложение в Visual Basic создается на базе формы, являющейся, как правило, основным окном интерфейса, с элементами управления, позволяющими осуществлять взаимодействие с пользователями.

В Visual Basic при создании форм разработчик может использовать шаблоны и мастера, а также конструктор форм. Конструктор форм предназначен для самостоятельной разработки формы с заданными свойствами или для изменения формы, созданной с помощью мастера.

Размещение элементов управления в форме осуществляется следующим образом:

1. На панели элементов управления выбирается необходимый компонент, на основе которого будет создан объект, размещаемый на форме, например TextBox

2. Курсор, принявший вид перекрестия, устанавливается в место предполагаемого размещения объекта в форме.

3. При нажатой левой кнопке мыши прорисовывается рамка требуемого размера. При этом рядом с курсором мыши появляются текущие размеры создаваемого объекта.

4. После того, как кнопка мыши будет отпущена, на форме появится изображение объекта.

Для сохранения проекта выполните следующие действия:

1. В меню File (Файл) выберите команду Save Project (Сохранить проект) или нажмите кнопку Save Project на стандартной панели инструментов.

2. В открывшемся диалоговом окне Save File As список Тип файла содержит значение Form Files, указывая, что сохраняется входящая в приложение форма (файл с расширением .frm). Используя раскрывающийся список Папка, выберите папку, в которой будет сохранена форма, затем в поле Имя файла введите имя формы и нажмите кнопку Сохранить.

3. Так как никаких компонентов, кроме формы, новое приложение не содержит, появляется диалоговое окно Save Project As (Сохранить проект как) для сохранения самого проекта (файлы с расширениями .vbp и vpw). По умолчанию в списке Папка выбрана папка, в которой сохранили форму. Введите наименование проекта и нажмите кнопку Сохранить.

При последующем сохранении проекта Visual Basic по умолчанию сохраняет файлы под их именами. Если же в проект с момента последнего сохранения были добавлены новые компоненты, откроется диалоговое окно Save File As для присвоения им имен.

Замечание: Для облегчения работы с проектом и входящими в его состав файлами, прежде чем сохранять проект, создайте отдельную папку, в которой затем и сохраните все файлы.

Создайте форму, показанную на рисунке, разместив на ней необходимые объекты и сохраните проект на диске в папке, указанной преподавателем.

Замечание: при создании формы используйте компоненты панели элементов управления General и Microsoft Windows Commom Controls 6.0

Сами создайте форму, разместив на ней различные объекты и сохраните проект на диске в папке, указанной преподавателем.

Контрольные вопросы:

1. Какие типы шаблонов можно использовать для создания проекта.

2. Перечислите основные элементы среды Visual Basic и укажите их назначение.

3. Какие основные команды можно выполнить с использованием инструментальной панели.

4. Для чего предназначен конструктор форм.

5. Какие функции можно выполнить с помощью панели элементов управления.

6. Что представляет собой редактор меню и каково его назначение.

7. Какие действия можно выполнить с помощью окна свойств.

8. Для чего предназначено окно просмотра объектов.

9. Для чего предназначено окно макета формы.

10. Что можно отредактировать с помощью редактора исходного кода.

11. Какие действия выполняются в проводнике проекта.

12. Для чего используются окна локальных переменных и контроля работы приложения.

13. Какие действия выполняются в окне ручного ввода и выполнения команд.

14. Какие параметры среды Visual Basic могут быть настроены.

15. Какие основные параметры настраиваются на вкладке настроек редактора.

16. Какие основные параметры настраиваются на вкладке стилей текста.

17. Какие основные параметры настраиваются на вкладке настроек общих свойств среды.

18. Какие основные параметры настраиваются на вкладке настройки окон.

19. Какие основные параметры настраиваются на вкладке Environment.

20. Какие основные параметры настраиваются на вкладке Advanced.


Лабораторная работа № 5

Разработка компонентов оконного программного интерфейса в интегрированной среде Visual Basic.

Цель работы: Изучение возможностей создания типовых компонентов интерфейса приложений Windows в среде Visual Basic.

Задачи:

- Получить практические навыки создания компонентов интерфейса, используя средства визуального проектирования в среде разработки приложений Visual Basic.

Задание на выполнение работы

1. Запустить Visual Basic и создать новый проект на основе шаблона

2. Создать проект, содержащий диалоговые (рабочие, управляющие) окна с элементами стандартного программного интерфейса приложений Windows.

3. Сохранить проект на диске.

4. Повторить пункты 2 и 3, создав и сохранив на менее 4-х различных проектов с рабочими, диалоговыми и управляющими окнами, 2 из которых должны быть полнофункциональными, то есть выполнять запрограммированные в них действия.

5. Продемонстрировать созданные проекты преподавателю и объяснить назначение составных элементов проекта преподавателю.

6. Составить отчет в MS Word, содержащий рисунки окон разработанного программного интерфейса и описание его назначения и основных компонентов.

Содержание отчета:

- группа и фамилия студента, дата выполнения лабораторной работы,

- фамилия преподавателя, ведущего лабораторный практикум,

- название работы, цель и задачи работы,

- экранные формы, характеризующие пользовательский интерфейс разработанной программы,

- тексты программ разработанных приложений

- описание программ и руководство пользователя программами.

Примечание: Для вставки рисунков в текст документа используйте программы снятия копий элементов и областей экранных форм (например программу HyperSnap или графический редактор MS Paint).

Методические указания (примеры интерфейса полнофункциональных приложений и исходные тексты программ)

Пример окна формы приложения для решения квадратного уравнения

Текст программы решения квадратного уравнения

Приложение, позволяющее возводить число в заданную в степень, извлекать корня заданной степени и вычислять факториал заданного числа.

Текст программы позволяющей возводить число в заданную в степень, извлекать корня заданной степени и вычислять факториал заданного числа.

ПРИМЕЧАНИЕ: Программы, разработанные студентами в процессе выполнения лабораторной работы должны иметь оригинальный (отличающийся от других программ) интерфейс. Программы с одинаковым интерфейсом и исходным текстом приниматься в качестве результата лабораторной работы не будут.


Лабораторная работа № 6

Разработка интерфейса программы на языке Visual Basic (на примере интерфейса для программы «Калькулятор»).

Цель работы: Изучение возможностей создания программы «калькулятор» и компонентов ее интерфейса в среде Visual Basic.

Задачи:

- Получить практические навыки создания компонентов интерфейса для приложения «калькулятор», используя средства визуального проектирования в среде разработки приложений Visual Basic.

Задание на выполнение работы

1. Запустить Visual Basic и создать новый проект на основе шаблона .

2. Спроектировать форму для программы «калькулятор».

3. Подготовить исходный код программы, обеспечивающей работы приложения «калькулятор».

4. Сохранить файл проекта на диске.

5. Выполнить тестирование программы для проверки корректности ее работы.

6. Создать выполнимый файл для возможности запуска программы «калькулятор» в ОС Windows.

7. Составить отчет о работе, используя текстовый процессор WordPad или MS Word.(пример оформления отчета см. в лабораторной работе №1).

Содержание отчета:

- группа и фамилия студента, дата выполнения лабораторной работы,

- фамилия преподавателя, ведущего лабораторный практикум,

- название работы, цель и задачи работы,

- тексты программы «калькулятор» с разработанным оконным интерфейсом,

- экранные формы, характеризующие пользовательский интерфейс разработанной программы «калькулятор»,

- содержание тестовых примеров и результаты тестирования разработанной программы «калькулятор»,

- описание программы «калькулятор» и руководство пользователя программой.

Примечание: Для вставки рисунков в текст документа используйте программы снятия копий элементов и областей экранных форм (например программу HyperSnap или графический редактор MS Paint).

Пример

Private Sub Command1_Click()

Text1 = Text1 + "1"

End Sub

Private Sub Command10_Click()

Text1 = Text1 + "0"

End Sub

Private Sub Command11_Click()

Text1 = Text1 + "."

End Sub

Private Sub Command12_Click()

strA = Text1

Text1 = ""

intIndex = 12

End Sub

Private Sub Command13_Click()

strA = Text1

Text1 = ""

intIndex = 13

End Sub

Private Sub Command14_Click()

strA = Text1

Text1 = ""

intIndex = 14

End Sub

Private Sub Command15_Click()

strA = Text1

Text1 = ""

intIndex = 15

End Sub

Private Sub Command16_Click()

Select Case intIndex

Case 12

Text1 = Val(strA) * Val(Text1)

Case 13

Text1 = Val(strA) / Val(Text1)

Case 14

Text1 = Val(strA) + Val(Text1)

Case 15

Text1 = Val(strA) - Val(Text1)

Case 18

Text1 = Val(strA) ^ Val(Text1)

Case 19

Text1 = Val(strA) ^ (1 / Val(Text1))

End Select

End Sub

Private Sub Command17_Click()

Text1 = ""

End Sub

Private Sub Command18_Click()

strA = Text1

Text1 = ""

intIndex = 18

End Sub

Private Sub Command19_Click()

strA = Text1

Text1 = ""

intIndex = 19

End Sub

Private Sub Command2_Click()

Text1 = Text1 + "2"

End Sub

Private Sub Command3_Click()

Text1 = Text1 + "3"

End Sub

Private Sub Command4_Click()

Text1 = Text1 + "4"

End Sub

Private Sub Command5_Click()

Text1 = Text1 + "5"

End Sub

Private Sub Command6_Click()

Text1 = Text1 + "6"

End Sub

Private Sub Command7_Click()

Text1 = Text1 + "7"

End Sub

Private Sub Command8_Click()

Text1 = Text1 + "8"

End Sub

Private Sub Command9_Click()

Text1 = Text1 + "9"

End Sub

Результаты тестирования программы

В разработанной программе не корректно обрабатывается деление на «0», извлечение корня из отрицательного числа…

ПРИМЕЧАНИЕ: Программы, разработанные студентами в процессе выполнения лабораторной работы должны иметь оригинальный (отличающийся от других программ) интерфейс. Программы с одинаковым интерфейсом и исходным текстом приниматься в качестве результата лабораторной работы не будут.


Лабораторная работа № 7

Разработка интерфейса программы на языке Visual Basic (на примере интерфейса для программы «Просмотрщик графических файлов»).

Цель работы: Изучение возможностей создания программы «Просмотрщик графических файлов» и компонентов ее интерфейса в среде Visual Basic.

Задачи:

- Получить практические навыки создания компонентов интерфейса для приложения «Просмотрщик графических файлов», используя средства визуального проектирования в среде разработки приложений Visual Basic.

Задание на выполнение работы

1. Запустить Visual Basic и создать новый проект на основе шаблона.

2. Спроектировать форму для программы «Просмотрщик графических файлов».

3. Подготовить исходный код программы, обеспечивающей работу приложения «Просмотрщик графических файлов».

4. Сохранить файл проекта на диске.

5. Выполнить тестирование программы для проверки корректности ее работы.

6. Создать выполнимый файл для возможности запуска программы «Просмотрщик графических файлов» в ОС Windows.

7. Составить отчет о работе, используя текстовый процессор WordPad или MS Word.(пример оформления отчета см. в лабораторной работе №1).

Содержание отчета:

- группа и фамилия студента, дата выполнения лабораторной работы,

- фамилия преподавателя, ведущего лабораторный практикум,

- название работы, цель и задачи работы,

- тексты программы «Просмотрщик графических файлов».

- экранные формы, характеризующие пользовательский интерфейс разработанной программы «Просмотрщик графических файлов»,

- описание программы «Просмотрщик графических файлов» и руководство пользователя программой.

Примечание: Для вставки рисунков в текст документа используйте программы снятия копий элементов и областей экранных форм (например программу HyperSnap или графический редактор MS Paint).

Методические указания (пример интерфейса программы «Смотрелка картинок и текста» исходный текст программы)

Создайте новый проект и разместите на форме элементы навигации по дискам (DriveListBox), каталогам (DirListBox) и файлам (FileListBox).

Поместите на форму графическое окно для вывода картинок (PictureBox)

Пример окна формы приложения «Смотрелка картинок и текста» с расположенными на ней объектами

Текст программы «Смотрелка картинок и текста»

Данная программа позволяет не только выводить кактинки в графическое окно, но и просматривать в нем содержимое текстовых файлов. Эта простейшая программа «Смотрелка картинок и текста» не позволяет выполнять скроллинг картинок и текста, непомещающегося в графическом окне.


Лабораторная работа № 8

Типовые ошибки, допускаемые при проектировании программного интерфейса.

Цель работы: Изучение типовых ошибок, допускаемых разработчиками программного интерфейса и их влияния на работу пользователя с приложением.

Задачи:

- изучить типовые ошибки, которые были допущены разработчиками программного интерфейса используя материалы сайта Isys Information Architects Inc (см. методические материалы в полной редакции).

- проанализировать влияние допущенных ошибок на работу пользователя с приложением,

- предложить пути устранения указанных ошибок путем изменения компонентов интерфейса.

Задание на выполнение работы

1. Изучить типовые ошибки, которые были допущены разработчиками программного интерфейса, используя описание, представленное в электронном виде «Дизайн программного интерфейса» (описание в формате .htm).

2. Составить таблицу, содержащую описание недостатков интерфейса и способов их устранения.

№ | Категория | Наименование элементов | Краткое описание | Создаваемые неудобства | Способ устранения | Программный продукт | Рис | Прим

3. Включить таблицу в отчет о работе подготовленный в текстовом процессоре WordPad или MS Word.

Содержание отчета:

- группа и фамилия студента, дата выполнения лабораторной работы,

- фамилия преподавателя, ведущего лабораторный практикум,

- название работы, цель и задачи работы,

- таблица, содержащая описания недостатков интерфейса и способов их устранения.

Примечание: Для вставки рисунков в текст документа используйте программы снятия копий элементов и областей экранных форм (например программу HyperSnap или графический редактор MS Paint).

Методические указания

Для составления описания выбрать 2-3 категории элементов и заполнить таблицу. Удобно использовать электронную таблицу MS Excel.

Пример таблицы

ПРИМЕЧАНИЕ: Описания, подготовленные студентами в процессе выполнения лабораторной работы должны включать различные категории элементов и быть оригинальными (отличающимися от других описаний). Одинаковые таблицы с описаниями приниматься в качестве результата лабораторной работы не будут.


Лабораторная работа № 9

Разработка интерфейса программы на языке Visual Basic (на примере интерфейса для программы «Шутка»).

Цель работы: Изучение возможностей создания программы «Шутка» и компонентов ее интерфейса в среде Visual Basic

Задачи:

- Получить практические навыки создания компонентов интерфейса для приложения «Шутка», используя средства визуального проектирования в среде разработки приложений Visual Basic.

Задание на выполнение работы

1. Запустить Visual Basic и создать новый проект на основе шаблона.

2. Спроектировать формы для программы «Шутка».

3. Подготовить исходный код программы, обеспечивающей работу приложения «Шутка».

4. Сохранить файл проекта на диске.

5. Выполнить тестирование программы для проверки корректности ее работы.

6. Создать выполнимый файл для возможности запуска программы «Шутка» в ОС Windows.

7. Составить отчет о работе, используя текстовый процессор WordPad или MS Word (пример оформления отчета см. в лабораторной работе №1).

Содержание отчета:

- группа и фамилия студента, дата выполнения лабораторной работы,

- фамилия преподавателя, ведущего лабораторный практикум,

- название работы, цель и задачи работы,

- тексты программы «Шутка»,

- экранные формы, характеризующие пользовательский интерфейс разработанной программы,

- описание программы «Шутка» и руководство пользователя программой.

Пример экранных форм программы «Шутка»

Первая экранная форма

Вторая экранная форма

Третья экранная форма

Четвертая экранная форма

Успеха Вам в создании интересных и бесполезных программ. Дерзайте!


Вопросы к зачету

по дисциплине: "Организация интерфейса в человеко-машинных системах"

Развитие аппаратных и программных средств взаимодействия с ЭВМ, понятие интерфейса.

1. История развития аппаратных средств взаимодействия с ЭВМ.

2. Классификация устройств ввода данных, использовавшихся на ЭВМ первого-четвертого поколения и их характеристики.

3. Классификация устройств вывода данных, использовавшихся на ЭВМ первого-четвертого поколения и их характеристики.

4. Интерактивные вычисления как новый этап в области развития человеко-машинного интерфейса.

5. Понятие человеко-машинного взаимодействия. Дисциплины, используемые в процессе создания человеко-машинного интерфейса и их значение.

Классификация и обзор современных аппаратных средств взаимодействия с компьютером.

6. Устройства ввода данных их назначение и характеристики.

7. Устройства управления компьютером их назначение и характеристики.

8. Устройства вывода данных их назначение и характеристики.

9. Устройства передачи данных их назначение и характеристики.

Современные программные средства взаимодействия с компьютером.

10. Операционные системы и прикладное программное обеспечение, их возможности в области организации человеко-машинного взаимодействия. Понятие стандартизации элементов интерфейса.

11. Компоненты интерфейса при работе с приложениями в МS DOS и их разработка.

12. Компоненты интерфейса при работе с приложениями в МS Windows: рабочее окно, текстовое меню, панель инструментов.

13. Компоненты интерфейса при работе с приложениями в МS Windows: диалоговое окно, строка состояния, кнопки управления, вкладки.

14. Компоненты интерфейса при работе с приложениями в МS Windows: метки, ключи, переключатели,

15. Компоненты интерфейса при работе с приложениями в МS Windows: текстовые редактируемые и не редактируемые поля, скрытые текстовые поля, поле для ввода числовой информации.

16. Компоненты интерфейса при работе с приложениями в МS Windows: список и, подсказки (всплывающие подсказки), линии и контуры, элемент управления типа Frame, индикаторы процесса выполнения программы, ползунки.

Основы объектно-ориентированного программирования

17. Технологии программирования, понятие объектно-ориентированного и визуального программирования.

18. Основные понятия объектно-ориентированного программирования: объект, свойства объекта, событие.

19. Основные понятия объектно-ориентированного программирования: инкапсуляция, наследование, полиморфизм.

20. Объекты, свойства и методы в среде Windows и MS Office.

Объектно-ориентированное событийное программирование на Visual Basic.

21. Назначение и возможности Visual Basic для создания интерфейса. Преимущества и недостатки Visual Basic в сравнении с другими языками.

22. Интегрированная среда разработки приложений. Основные компоненты среды Visual Basic.

23. Переменные, константы и типы данных.

24. Программирование условий, организация циклов.

25. Ввод и вывод данных, элементы интерфейса, используемые для ввода/вывода данных: диалоговые окна (окно сообщения, окно ввода информации).

26. Работа со строками, работа с файлами, стандартные элементы интерфейса для работы с файлами (диалоговое окно открытия файла и окно сохранения файла).

27. Структура программы на Visual Basic.

28. Типы интерфейсов, создаваемых в Visual Basic.

29. Проектирование основных компонентов интерфейса в Visual Basic: главное и контекстное меню, панель инструментов.

30. Проектирование компонентов интерфейса в Visual Basic: диалоговое окно настройки цветовой палитры, диалоговое окно настройки шрифтов текста.

31. Проектирование компонентов интерфейса в Visual Basic: элемент управления ProgressBar, элемент управления UpDown, элемент управления MonthView.

32. Понятие «Шаблон» Visual Basic. Примеры шаблонов для создания компонентов интерфейса: About Dialog и Dialog.

33. Понятие «Шаблон» Visual Basic. Примеры шаблонов для создания компонентов интерфейса: Log in Dialog, Splash Screen, Tip of the Day.

Основные принципы создания интерфейса и рекомендации по его разработке.

34. Понятия: «стандартизация», «удобство и простота работы», «естественность (интуитивность)», «внешний дизайн» и их значение для процесса проектирования программного интерфейса.

35. Понятия: «непротиворечивость», «неизбыточность», «непосредственный доступ к системе помощи», «гибкость» и их значение для процесса проектирования программного интерфейса.

36. Понятия: «неперегруженность форм», «группировка», «разреженность объектов форм» и их значение для процесса проектирования программного интерфейса.

37. Рекомендации по рациональному размещению информации на экране, непротиворечивость и стандартизация, тексты и диалоги как элемент интерфейса.

38. Выделение элементов интерфейса яркостью и использование цвета при проектировании эргономичного интерфейса.

Особенности проектирования средств управления графического интерфейса пользователя.

39. Кнопки и иконки, их назначение и классификация.

40. Типовые варианты организации меню и основные принципы его проектирования.

41. Основные принципы проектирования форм, дизайн заголовков и полей, форматы ввода данных.

42. Организация системы навигации и системы отображения состояний программного приложения.

43. Проектирование сообщений для направления действий пользователя в процессе работы с системой.

44. Принципы и подходы, реализуемые в процессе проектирования программного интерфейса, направленные на предотвращение, обнаружение и исправление ошибок пользователя. Обработка ошибок в формах ввода.

45. Типовые ошибки, допускаемые при проектировании программного интерфейса.


Интегрированная среда визуального объектно

Интегрированная среда
визуального объектно-ориентированного программирования Visual Basic 6.0

на главную страницу

Начало работы.. 2

Компоненты рабочей среды.. 3

Главное меню.. 3

Стандартная панель инструментов. 4

Окно конструктора форм.. 4

Панель элементов управления. 5

Окно редактора меню.. 5

Окно свойств. 6

Окно просмотра объектов. 7

Окно макета формы.. 8

Окно редактора исходного кода. 8

Окно проводника проекта. 8

Окно локальных переменных. 9

Окно контроля работы приложения. 9

Окно ручного ввода и выполнения команд.. 10

Настройка среды разработки. 10

Вкладка настроек редактора. 11

Вкладка стилей текста. 12

Вкладка настроек общих свойств среды.. 12

Вкладка настройки окон. 13

Вкладка Environment 14

Вкладка Advanced. 14

ПРИЛОЖЕНИЕ.. 16

Команды меню File. 16

Команды меню Edit 16

Команды меню View.. 17

Команды меню Project 17

Команды меню Format 18

Команды меню Debug. 18

Команды меню Run. 18

Команды меню Query. 18

Команды меню Diagram.. 19

Команды меню Tools. 19

Команды меню Add-Ins. 20

Команды меню Window.. 20

Команды меню Help. 20

Кнопки стандартной панели инструментов. 20

Кнопки панели элементов управления. 21

Начало работы

При запуске Visual Basic 6 на экране появляется диалоговое окно New Project (Новый проект), используя которое можно выбрать шаблон для нового проекта, запустить мастера создания проекта или открыть ранее созданный проект (рис. 1).

Рис. 1 Окно создания проекта

Это окно содержит вкладки следующего назначения:

- New (Новый) — содержит шаблоны и мастера для создания нового проекта;

- Existing (Существующий) — позволяет открыть ранее созданный проект или проекты-примеры, поставляемые с Visual Basic 6. Вкладка имеет раскрывающийся список, с помощью которого можно выбрать любую папку на имеющихся ресурсах компьютера;

- Recent (Недавно созданный) — содержит список проектов, открывавшихся в последнее время;

Для создания нового проекта используется вкладка New. На ней можно выбрать один из следующих типов шаблона проекта:

- Standard EXE — стандартное выполняемое приложение;

- ActiveX EXE — выполняемое приложение ActiveX;

- ActiveX DLL — динамическая библиотека ActiveX;

- ActiveX Control — элемент управления ActiveX;

- VB Application Wizard — мастер приложений;

- VB Wizard Manager — мастер создания пользовательских мастеров;

- Data Project — проект управления базой данных;

- IIS Application — приложение, размещаемое на сервере Web-узла (IIS — Internet Information Server);

- Addin — надстройка, дополнительные утилиты, расширяющие возможности приложений;

- ActiveX Document DLL — динамическая библиотека документов ActiveX;

- ActiveX Document EXE — выполняемое приложение документов ActiveX;

- DHTML Application — приложение, создающее динамические HTML-страницы.

к началу

Компоненты рабочей среды

После выбора типа проекта пользователь переходит непосредственно в инструментальную среду проектирования Visual Basic 6. Ее внешний вид показан на рис. 2

Рис. 2 Инструментальная среда Visual Basic 6.

Элементы среды:

- главное меню;

- стандартная панель инструментов;

- панель элементов управления;

- окно проводника проекта (Project);

- конструктор форм;

- окно свойств (Properties);

- окно макета формы (Form Layout);

- окно просмотра объектов (Object Browser);

- редактор исходного кода.

к началу

Главное меню

Главное меню, как и во всех приложениях Microsoft, представляет собой линейку раскрывающихся меню. Оно содержит следующие основные команды: File (Файл), Edit (Правка), View (Вид), Project (Проект), Format (Формат), Debug (Отладка), Run (Запуск), Query (Запрос), Diagram (Диаграмма), Tools (Сервис), Add-Ins (Надстройки), Window (Окно), Help (Справка).

Наиболее часто используемые команды меню отображены в виде кнопок со значками на стандартной панели инструментов, размещенной ниже меню. Рассмотрим основные команды главного меню.

Меню File (Файл) содержит команды для работы с файлами проекта. Используя эти команды, можно выполнять такие действия, как создание нового проекта, открытие проекта для внесения изменений, добавление проекта для параллельной работы над несколькими проектами или копирование форм из проекта в проект и т. п. Все команды этого меню перечислены в табл. 1- 13 Приложения.

Меню Edit (Правка) содержит команды, предназначенные для редактирования. Часть из них соответствует подобным командам редактирования других приложений Microsoft, например, отменить предыдущую команду, повторить предыдущую команду, вырезать фрагмент текста, скопировать фрагмент в буфер обмена. В составе этого меню целый набор команд для работы с таблицами базы данных: добавлять и удалять поля, назначать первичный ключ в таблице базы данных.

Меню View (Вид) содержит команды вызова окон и панелей инструментальной среды Visual Basic 6.

Меню Project (Проект) содержит команды управления проектом и его элементами. Они позволяют добавить в проект и удалить из него элементы проекта, такие как форма, программный модуль, класс и другие. С помощью команд данного меню вы также можете открыть окно свойств приложения, добавить ссылки на подключаемые библиотеки, добавить дополнительные компоненты на панель элементов.

Меню Format (Формат) содержит большое количество команд форматирования объектов в форме.

Меню Debug (Отладка) содержит команды, предназначенные для отладки приложения. Используя команды этого меню, можно установить точки останова программы и проверить значения выражении и переменных, выполняя программу по шагам.

Меню Run (Запуск) содержит команды управления запуском приложения. Используя команды данного меню, можно запустить приложение на выполнение с компиляцией или без компиляции, приостановить или прервать выполнение приложения.

Меню Query (Запрос) содержит команды создания и выполнения запросов к базе данных. При помощи этого меню, например, можно выполнить запрос, преобразовать результаты запроса в табличный вид.

Меню Diagram (Диаграмма) содержит команды построения диаграммы, отображающей структуру базы данных.

Меню Tools (Сервис) содержит команды управления настройками инструментария среды Visual Basic 6. Они позволяют добавить процедуру и определять ее атрибуты, вызвать окно редактора меню, изменить настройки программы в диалоговом окне Options (Параметры), а также управлять хранилищем проектов SourseSafe.

Меню Add-Ins (Надстройки) содержит команды вызова дополнительных утилит, часто называемых надстройками (add-ins).

Меню Window (Окно) содержит стандартные команды управления окнами. При вызове окон приложения меню Window пополняется соответствующими командами активизации окон приложения. При этом команды активизации окон называются по именам открытых окон.

Меню Help (Справка) содержит команды вызова справочной системы Visual Basic 6. При помощи этого меню можно вызывать справочную систему с различными вариантами представления информации. Отличие между ними состоит в открывающейся по умолчанию вкладке.

к началу

Стандартная панель инструментов

Команды, которые часто используются при работе, можно разместить в виде кнопок на панели инструментов. Можно также исключить из панели редко применяемые команды.

Кнопки панели инструментов снабжены всплывающими подсказками.

Стандартная панель инструментов, расположенная под главным меню, показана на рис. 3 (в том виде, в каком она настроена при установке Visual Basic 6).

Рис. 3 Стандартная панель инструментов

Если эта панель отсутствует в главном окне программы, для ее отображения в меню View (Вид) выберите команду Toolbars (Панели инструментов), а затем значение Standard (Стандартная).

На стандартной панели инструментов расположены кнопки для вызова наиболее часто употребляемых команд меню. Вы можете изменить расположение стандартной панели инструментов, разместив ее в нижней части главного окна, справа или слева. Для этого с помощью кнопки мыши захватите любую границу панели и переместите ее в любое удобное для вас место.

Описание наиболее часто используемые команд панели инструментов приведено в табл. 14 Приложения.

к началу

Окно конструктора форм

Окно конструктора форм является основным рабочим окном, в котором выполняется визуальное проектирование приложения. Это окно показано на рисунке.

Рис. 4 Окно конструктора форм

Вызвать это окно можно из главного меню командой Object (Объект) меню View (Вид) или командой View Object контекстного меню объекта, находящегося в группе Forms в проводнике проекта.

В окне конструктора форм визуально конструируются все формы приложения с использованием инструментария среды разработки.

Для точного позиционирования объектов в форме в окне имеется сетка. Размер ячеек сетки можно менять. При необходимости сетку можно отключать, воспользовавшись параметрами диалогового окна Options, открываемого командой Options (Параметры) из меню View (Вид).

Размер формы в окне можно изменять, используя маркеры выделения формы и мышь. Для изменения размера формы необходимо установить указатель мыши на маркер и, когда он примет вид двунаправленной стрелки, перемещать до получения требуемого размера.

к началу

Панель элементов управления

Панель элементов управления — основной рабочий инструмент при визуальной разработке форм приложения (рис. 5).

Панель элементов управления вызывается из меню View (Вид) командой Toolbox (Панель элементов управления). Для вызова этой панели можно воспользоваться также кнопкой Toolbox на стандартной панели инструментов.

Рис. 5. Панель элементов управления Visual Basic 6

В составе панели элементов управления содержатся основные элементы управления форм — метки, текстовые поля, кнопки, списки и другие элементы для быстрого визуального проектирования макета формы. На панели представлены кнопки, назначение которых описано в табл. 1.15.

Для размещения элементов управления в форме с помощью панели элементов выполните следующие действия:

1. Выделите требуемый элемент управления с помощью мыши.

2. Перейдите в окно конструктора форм. Указатель мыши при этом превратится в крестик, при помощи которого можно установить местоположение размещаемого объекта. Левой кнопкой мыши зафиксируйте позицию нового объекта и, удерживая кнопку, задайте размеры объекта.

к началу

Окно редактора меню

В окне редактора меню Menu Editor (рис. 6) можно создавать или редактировать строку меню для формы.

Рис. 6 Окно редактора меню

Для проектирования меню всех видов используется редактор меню Menu Editor (Редактор меню) среды проектирования IDE.

Редактор меню вызывается одним из следующих способов:

- командой Menu Editor (Редактор меню) меню Tools (Инструменты);

- нажатием кнопки Menu Editor на стандартной панели инструментов;

- нажатием комбинации клавиш <Ctrl>+<E>.

Редактор создает меню для активного в данный момент окна, то есть, если активно MDI-OKHO, проектируется меню для него, если активна дочерняя форма, проектируется меню для дочерней формы.

к началу

Окно свойств

Окно Properties (Свойства) предназначено для отображения и настройки свойств формы, а также размещенных в ней объектов. В нем, например, содержатся такие свойства выбранного объекта, как позиция в форме, высота, ширина, цвет (рис. 7).

Рис. 7 Окно свойств

Диалоговое окно Properties вызывается командой Properties Window (Окно свойств) из меню View (Вид), кнопкой Properties Window на стандартной панели инструментов или командой Properties контекстного меню выбранного объекта. Поскольку форма и элементы управления каждый сами по себе являются объектами, набор свойств в этом окне меняется в зависимости от выбранного объекта. При помощи вкладок Alphabetic (По алфавиту) и Categorized (По категориям) свойства объекта можно просмотреть в алфавитном порядке или по группам (категориям) соответственно.

В нижней части окна вы всегда найдете подсказку, поясняющую назначение выбранного атрибута объекта. Более подробную информацию найдете в справочной системе Visual Basic 6, нажав клавишу <Fl>. При этом необходимо предварительно выделить интересующее вас свойство.

Используя диалоговое окно Properties, можно изменить установленные по умолчанию свойства объектов. Часть свойств объекта, например, размеры и расположение объектов, можно задать перемещением объекта и изменением его размеров с помощью мыши в конструкторе форм.

Свойства, установленные в окне свойств, допускается изменять при выполнении приложения, написав соответствующие коды в процедурах, создаваемых с помощью редактора кода.

Как правило, форма содержит много объектов. Если выбрать сразу несколько объектов, то в окне свойств отобразятся общие для этих объектов свойства.

В начале изучения Visual Basic 6 в окне свойств Properties предпочтительнее пользоваться вкладкой Categorized (По категориям), так как на ней все свойства сгруппированы по типам и поэтому более понятны. На рис. 6 показана именно эта вкладка. В дальнейшем лучше пользоваться вкладкой Alphabetic (По алфавиту), где требуемое свойство можно быстрее найти по алфавиту.

Рассмотрим основные группы свойств, представленные на вкладке Categorized окна Properties.

Свойства, определяющие внешний вид объекта.

В группе Appearance (Оформление) окна Properties содержатся свойства объекта, которые задают атрибуты его внешнего вида. Основные свойства данной группы:

Caption | - задает текст в строке заголовка объекта;
BorderStyle | - задает стиль рамки объекта;
Palette | - устанавливает цветовую палитру;
Picture | - назначает значок, картинку для объекта. Используя данное свойство формы, можно задать фоновое графическое изображение.

Свойства, определяющие поведение объекта.

Свойства объектов, отвечающие за их поведение, собраны в группе Behavior (Поведение). Основные свойства данной группы:

Causes Validation | - устанавливает признак проверки условия достоверности данных при выходе из объекта;
Enabled | - разрешает или запрещает доступ к объекту;
MaxLength | - устанавливает максимальную длину данных в объекте;
Visible | - устанавливает видимость объекта.

Свойства, определяющие шрифт

Группа Font (Шрифт) содержит всего одно свойство Font, позволяющее с помощью диалогового окна Выбор шрифта задать шрифт текста объекта, размер, начертание.

Общие свойства

Свойства группы Misc задают общие атрибуты объекта, в том числе для его идентификации.

Name | - задает имя объекта;
Text | - устанавливает текст в поле по умолчанию;
Index | - задает уникальный индекс объекта в коллекции;

По имени, указанному в свойстве Name (Имя), объект идентифицируется в форме и в тексте программы. Поэтому необходимо иметь в виду, что в одной форме не может быть двух объектов с одинаковыми именами. По умолчанию это свойство устанавливается автоматически. Вместо имени, заданного по умолчанию, лучше использовать имя, отражающее его смысловое значение.

Свойства позиционирования

Группа Position (Расположение) окна Properties служит для позиционирования объектов в системе координат формы и установки размеров объектов.

Left | - задает положение объекта по горизонтальной оси от левого края формы или, в общем случае, от объекта-контейнера;
Top | - задает положение объекта по вертикальной оси от его верхнего края до верхней стороны формы;
Width | - задает горизонтальный размер (ширину) объекта;
Height | - задает вертикальный размер (высоту) объекта.

Свойства шкалы размеров объекта

Свойства группы Scale (Масштаб) устанавливают шкалу максимальных размеров объектов в системе координат формы.

ScaleLeft | - задает максимальное положение объекта по горизонтальной оси;
ScaleTop | - задает максимальное положение объекта по вертикальной оси;
ScaleWidth | - задает максимальный горизонтальный размер (максимальная ширина);
ScaleHeight | - задает максимальный вертикальный размер (максимальная высота).

к началу

Окно просмотра объектов

Для просмотра всех элементов, входящих в состав проекта. Visual Basic 6 предоставляет очень удобную возможность — окно просмотра объектов Object Browser (рис. 8).

Рис. 8. Окно просмотра объектов

В этом окне можно получить доступ не только ко всем элементам, которые входят в проект, но и их свойствам, методам, событиям. Окно просмотра объектов обычно не визуализировано и его можно вызвать командой Object Browser (Браузер объектов) из меню View (Вид).

к началу

Окно макета формы

Окно макета формы Form Layout (Макет формы) (рис. 9) вызывается командой Form Layout Window из меню View.

Рис. 9. Окно макета формы

В этом окне показывается уменьшенное изображение проектируемой формы в том виде, как эта форма будет выглядеть на экране монитора при выполнении приложения. Размеры формы в окне макета Form Layout пропорциональны размерам изображения монитора в этом же окне, то есть все реальные пропорции в точности соблюдены. Для проверки формы в работающем приложении откройте окно макета формы и запустите форму командой Start (Старт) из меню Run (Запуск).

При этом форма запускается точно в том виде, как она будет выглядеть в работающем приложении.

к началу

Окно редактора исходного кода

Редактор кода (рис. 10) — это мощный встроенный редактор с удобными средствами ввода исходного кода программы.

Рис.10 Редактор кода

Из меню View (Вид) перейти в редактор кода можно с помощью команды Code (Код). Для быстрого открытия окна редактора кода достаточно дважды щелкнуть левой кнопкой мыши, установив указатель на форме приложения. После начала редактирование кода программы имя открытого окна появляется и в списке команд перехода между окнами Window (Окно) главного меню. Переход между макетом и окном редактора кода можно выполнять, используя список меню Window.

Рис. 10. Окно редактора исходного кода

к началу

Окно проводника проекта

Окно проводника проекта Project (рис. 11) очень похоже на аналогичное окно проводника системы Windows и позволяет легко и быстро просматривать состав и свойства выбранного проекта, перемещаться между проектами, если их открыто сразу несколько, копировать необходимые объекты из окна одною проекта в другой, как это осуществляется в проводнике системы Windows.

Рис. 11. Окно проводника проекта

Проводник проекта можно вызвать командой Project Explorer (Проводник проекта) меню View (Вид) или комбинацией клавиш <Ctrl>+<R>.

При нажатии правой кнопки мыши в окне проводника появляется контекстное меню, содержащее команды для добавления, сохранения, удаления форм, элементов управления и других объектов.

Панель управления окна проводника проекта содержит три кнопки, которые имеют следующее назначение:

View code | - открывает окно редактора с кодом программы, выбранного в проводнике объекта;
View Object | - открывает в конструкторе форм выбранный объект;
Toggle Folders | - включает/выключает отображение папок.

к началу

Окно локальных переменных

Окно Locals (Локальные) предназначено для просмотра списка локальных переменных приложения и контроля за их значениями (рис. 12). Вызывается это окно командой Locals Window (Окно локальных переменных) меню View (Вид).

Рис. 12. Окно Locals

В окне Locals можно просмотреть локальные переменные, объявленные в текущей процедуре, их тип и значения. Эта информация автоматически появляется в окне при его вызове. Данное окно используется для отладки и проверки работы приложений. С помощью него можно проконтролировать все локальные переменные в точках останова программы.

При работе с окном Locals (Локальные) необходимо иметь в виду, что глобальные переменные в этом окне для просмотра недоступны.

Для выбора интересующей процедуры используется поле со списком. Нажав на кнопку с многоточием, можно выбрать интересующую процедуру из списка. Если значения переменных или их названия не помещаются в столбцах, то требуемые столбцы можно расширить, перемещая при помощи левой кнопки мыши границы столбцов в заголовке. Если окно открыто постоянно, то данные между точками останова программы при работе приложения автоматически обновляются.

В окне Locals можно не только просматривать переменные и их значения в данный момент работы программы. Очень полезным свойством этого окна является возможность изменять значения переменных для проверки реакции программы на эти значения. Для этого в столбце Value (Значение) необходимо щелкнуть на изменяемом значении. При этом значение переведется в режим редактирования, и его можно будет изменить. Клавишей <Enter> или перемещением указателя мыши на другое поле устанавливается новое значение, если оно имеет допустимое значение.

к началу

Окно контроля работы приложения

Для более полного контроля работы приложения (рис. 13) используется окно Watches (Наблюдение).

Рис. 13. Окно Watches

Это окно вызывается командой Watch Window (Окно наблюдения) меню View (Вид) и предназначено для определения значений выражений. В окне Watches можно выполнять действия, аналогичные выполняемым в окне Locals (Локальные). Так же, как и Locals, окно Watches используется при отладке приложения и проверке его работы.

к началу

Окно ручного ввода и выполнения команд

Окно Immediate (Непосредственное выполнение) предназначено для ручного ввода и выполнения команд Visual Basic 6 (рис. 14). Это окно появляется автоматически при прерывании работы программы в точках останова программы.

Рис. 14. Окно Watches

Для выполнения команды или оператора Visual Basic необходимо набрать строку команды и нажать клавишу <Enter>.

В сочетании с окнами Locals (Локальные) и Watches (Наблюдение), окно Immediate является удобным средством для отладки и проверки работы программы в пошаговом режиме. Проверяемые части или блоки программы можно копировать из программных модулей приложения в окно Immediate, и после проверки и внесения необходимых изменений по результатам контроля возвращать в модуль приложения.

к началу

Настройка среды разработки

Для настройки среды разработки программы Visual Basic используется диалоговое окно Options (Параметры), вызываемое из меню Tools (Сервис) командой Options (Параметры). Окно содержит шесть вкладок:

Editor (Редактор)

Editor Format (Форматы редактирования)

General (Основные настройки)

Docking (Инструменты среды)

Environment (Среда проектирования)

Advanced (Расширенные настройки)

Для настройки среды разработки (IDE) на вкладках используются группы флажков, переключателей, раскрывающиеся списки.

При изменении параметров для сохранения варианта настройки необходимо выйти из диалогового окна Options, нажав кнопку ОК.

Для отказа от всех осуществленных на вкладках изменений нажмите кнопку Отмена.

Рис. 15 Вкладка Editor

Рис. 16 Вкладка Editor Format

к началу

Вкладка настроек редактора

Самая первая вкладка диалогового окна Options — Editor (Редактор) (рис. 15). Здесь можно установить параметры работы редактора исходного кода приложения. Используя флажки группы Code Settings (Установки редактора кода), устанавливаются следующие параметры:

Auto Syntax Check (Автоматический контроль синтаксиса) | — автоматический контроль синтаксиса при вводе исходного кода приложения в редакторе;
Require Variable Declaration (Требование объявления переменных) | — если этот флажок установлен, любые переменные можно использовать только после их объявления;
Auto List Members (Автоматический вывод списка возможных свойств и методов объекта) | — автоматический вывод свойств и методов объекта при вводе текста программы. При этом методы и свойства отображаются в позиции курсора и их можно легко выбрать;
Auto Quick Info (Автоматический вывод синтаксиса функций) | — разрешение или запрет вывода информации о функциях и их параметрах при вводе текста программы;
Auto Data Tips (Автоматическое отображение значений) | — при отладке приложения отображает значение переменной, находящейся под указателем мыши;
Auto Indent (Автоматическая расстановка) | — автоматическая расстановка отступа при вводе программы. Отступы делают программу структурированной и понятной при чтении. Для сложных программ отступы просто обязательны.

В поле Tab Width указывается количество пробелов отступа при нажатии клавиши <ТаЬ>. По умолчанию установлено значение 8, но его можно изменить.

В группе Window Settings (Настройки окна) устанавливаются параметры, связанные с фрагментами текста:

Drag-and-Drop Text Editing (Перетаскивание текста) | — разрешает перетаскивание фрагментов текста программы;
Default to Full Module View (Отображение всех процедур) | — позволяет отображать в редакторе сразу все процедуры текущего объекта. Если этот флажок не установлен, процедуры можно просматривать по очереди;
Procedure Separator (Разделитель текста процедур) | — в режиме просмотра всех процедур проекта устанавливает между ними разделитель.

к началу

Вкладка стилей текста

На вкладке Editor Format (рис. 16) настраиваются стили текста исходного кода приложения — используемый шрифт, цвета, размер текста исходного кода в зависимости от назначения текста кода. Используя параметры данной вкладки, можно выделить цветом, шрифтом и размером шрифта основные элементы программы, например, основной текст, текст комментариев, точки остановки.

Для настройки форматов элементов кода необходимо выполнить следующее:

1. Выбрать в области Code Colors из списка типов программного текста настраиваемый тип.

2. Используя раскрывающиеся списки Foreground и Background, установить цвет текста и фона.

3. С помощью списков Font и Size задать наименование шрифта и его размер.

4. В области Sample просмотреть полученный результат осуществленных изменений.

5. Повторяя пункты с 1-го по 4-й, изменить все необходимые стили текста окна редактора кода.

6. Для сохранения установленных параметров, нажать кнопку ОК.

Рис. 17 Вкладка General

Рис. 18 Вкладка Docking

к началу

Вкладка настроек общих свойств среды

На вкладке General (рис. 17) диалогового окна Options размещены параметры, которые предназначены для управления общими свойствами среды проектирования. В области Form Grid Settings (Настройка сетки форм) находятся следующие параметры настройки:

Show Grid (Отображать сетку) | — устанавливает режим отображения линий координатной сетки при разработке макетов форм. Используя расположенные под флажком поля Width (Ширина) и Height (Высота), можно установить ширину и высоту ячеек сетки.
Align Controls to Grid (Привязать элементы управления к сетке) | — задает привязку элементов управления к шагу сетки при размещении их в макете формы.

В области Error Trapping (Реакция на ошибки) можно установить один из трех переключателей, которые задают вариант реакции приложения на возникающие при его работе ошибки:

Break on All Errors (Приостанавливаться по всем ошибкам) | — приостанавливать выполнение приложения при возникновении любой ошибки;
Break in Class Module (Приостанавливаться по ошибкам в классах) | — приостанавливать выполнение приложения при возникновении любой ошибки в модуле класса;
Break on Unhandled Errors (Приостанавливаться по неуправляемым ошибкам) | — приостанавливать выполнение приложения при возникновении любой необработанной ошибки, то есть при такой ошибке, для которой нет функции перехвата.

В области Compile (Компиляция) можно установить флажки, управляющие процессом компиляции программы:

Compile on Demand (Компиляция по мере необходимости) | — компиляция будет осуществляться только для тех разделов программы, которые необходимо выполнять. При этом при выполнении команды Start (Запустить) из меню Run (Запуск) приложение будет запускаться быстрее;
Background Compile (Фоновая компиляция) | — этот флажок дает возможность использовать время ожидания программы для ее компиляции.

Кроме перечисленных параметров, на этой вкладке есть еще два флажка следующего назначения:

Show ToolTips (Отображать подсказки) | — при установке этого флажка Visual Basic 6 отображает подсказку с описанием свойств объекта в макете формы, когда указатель мыши удерживается на объекте некоторое время;
Collapse Proj, Hides Windows (Сворачивать проект, скрыть окна) | — этот флажок заставляет сворачиваться все связанные с проектом окна при свертывании окна проекта.

к началу

Вкладка настройки окон

На вкладке Docking (рис. 18) диалогового окна Options все флажки объединены в одну группу Dockable Эти флажки определяют, какие окна среды разработки могут закрепляться ("приклеиваться") к краям главного окна программы Visual Basic. Наименования окон среды разработки перечислены в виде флажков. Настройка заключается в установке флажков для соответствующих им окон.

Immediate Window | — окно Immediate (Непосредственное выполнение)
Locals Window | — окно Locals (Локальные)
Watch Window | — окно Watches (Наблюдение)
Project Explorer | — проводник проекта
Properties Window | — окно свойств
Object Browser | — браузер объектов
Form Layout | — окно макета форм
Toolbox | — панель элементов управления
Color Palette | — цветовая палитра

Рис. 19 Вкладка Environment

Рис. 20 Вкладка Advanced

к началу

Вкладка Environment

Вкладка Environment (рис. 19)диалогового окна Options содержит три области. В области When Visual Basic starts (При запуске Visual Basic) можно установить переключатели:

Prompt for project (Приглашение для выбора образца проекта) | — указывает на необходимость открытия диалогового окна New Project (Новый проект) при запуске Visual Basic 6;
Create default project (Создавать проект по умолчанию) | — при запуске Visual Basic 6 создается установленный по умолчанию тип проекта.

Область When a program starts (При запуске программы) управляет возможностью сохранения проекта при запуске его на выполнение. Впоследствии при работе с большим проектом от сохранения можно отказаться для экономии времени. В данной группе переключателей устанавливается одна из следующих опций:

Save Changes (Сохранять изменения) | — сохранять изменения всегда;
Prompt To Save Changes (Сохранять изменения по запросу) | — сохранять проект с предварительным запросом на сохранение;
Don't Save Changes (He сохранять изменений) | — не сохранять осуществленных изменений.

Область Show Templates For (Показывать шаблоны) содержит список шаблонов, появляющихся в соответствующих диалоговых окнах при создании объектов. Используя расположенные здесь флажки, можно отказаться от части шаблонов, которые в данный момент не интересны. Для этого необходимо снять соответствующий флажок. Например, если вы не хотите, чтобы при создании форм появлялось диалоговое окно со списком шаблонов форм, вам необходимо снять флажок Form.

Поле Template Directory (Каталог шаблонов) вкладки назначает папку поиска шаблонов по умолчанию.

к началу

Вкладка Advanced

На вкладке Advanced (рис. 20) диалогового окна Options расположены три флажка, имеющих следующее назначение:

Background Project Load (Фоновая загрузка проекта) | — разрешает загрузку проекта в фоновом режиме, что дает возможность во время загрузки другого проекта продолжать работу над текущим;
Notify when changing shared project items (Сообщать об изменениях элементов проекта) | — сообщает об изменении общего для нескольких проектов объекта при одновременной работе над этими проектами;
SDI Development Environment (Назначить однодокументныи интерфейс) | — устанавливает однодокументныи интерфейс (SDI, Single-Document Interface) среды проектирования. По умолчанию используется многодокументный интерфейс (MDI, Multiple-Document Interface).

Используя поле External HTML Editor (Внешний редактор HTML) вкладки Advanced, можно установить редактор для работы с HTML-страницами.

к началу

ПРИЛОЖЕНИЕ

Команды меню File

Команда | Назначение
New Project (Новый проект) | Создает новый проект
Open Project (Открыть проект) | Открывает существующий проект
Add Project (Добавить проект) | Добавляет проект в группу для параллельной работы над несколькими проектами, копирования форм из проекта в проект или для его отладки
Remove Project (Исключить проект) | Удаляет проект из группы проектов
Save Project Group (Сохранить группу проектов) | Сохраняет группу проектов
Save Project Group As (Сохранить группу проектов как) | Сохраняет группу проектов под другим именем
Save <имя формы> (Сохранить форму) | Сохраняет форму с прежним именем
Save <имя формы> As (Сохранить форму как) | Сохраняет форму под другим именем
Print (Печать) | Открывает диалоговое окно Print
Print Setup (Настройка печати) | Открывает диалоговое окно настройки печати
Make <имя проекта>.ехе (Создать ехе-файл проекта) | Создает выполняемый файл текущего проекта
Make Project Group (Создать группу проектов) | Создает группу проектов
Exit (Выход) | Осуществляет выход из Visual Basic 6. В том случае, если в окне программы находятся не сохраненные результаты работы, появятся запросы о необходимости сохранения проектов, форм и других файлов

к началу

Команды меню Edit

Команда | Назначение
Undo (Отменить) | Отменяет предыдущую команду
Redo (Повторить) | Восстанавливает предыдущую команду
Cut (Вырезать) | Вырезает фрагмент текста
Сору (Копировать) | Копирует фрагмент в буфер обмена
Paste (Вставить) | Копирует содержимое из буфераобмена
Remove (Переместить) | Перемещает выделенное
Delete (Удалить) | Удаляет выделенное
Delete Table from Database (Удалить таблицу из базы данных) | Удаляет таблицу из базы данных
Select All (Выделить все) | Выделяет все
Select All Columns (Выделить все колонки) | Выделяет все колонки
Table: Set Primary Key (Таблица: Установить первичный ключ) | Определяет первичный ключ таблицы
Table: Insert Column (Таблица: Вставить поле) | Вставляет поле в таблицу
Table: Delete Column (Таблица: Удалить поле) | Удаляет поле из таблицы
Find (Найти) | Вызывает диалоговое окно поиска
Find Next (Найти следующее) | Ищет следующее значение, заданное для поиска
Replace (Заменить) | Ищет значение, заданное для поиска, и заменяет его новым значением
Go To Row: First (Перейти на запись: Первая) | Устанавливает указатель на первую запись
Go To Row: Last (Перейти на запись: Последняя) | Устанавливает указатель на последнюю запись
Go To Row: Next (Перейти на запись: Следующая) | Устанавливает указатель на следующую запись
Go To Row: Previous (Перейти на запись: Предыдущая) | Устанавливает указатель на предыдущую запись
Go To Row: Row (Перейти на запись: Запись) | Устанавливает указатель на запись с заданным номером
Go To Row: New (Перейти на запись: Новая) | Вставляет новую запись

к началу

Команды меню View

Команда | Назначение
Code (Код) | Открывает окно редактора программного кода
Object (Объект) | Открывает окно конструктора форм
Object Browser (Браузер объектов) | Открывает окно браузера объектов
Immediate Window (Окно непосредственного выполнения) | Открывает окно, предназначенное для ввода и непосредственного выполнения команд
Locals Window (Окно Локальные) | Открывает окно, предназначенное для просмотра значений переменных
Watch Window (Окно Наблюдение) | Открывает окно просмотра значений выражений
Project Explorer (Проводник проекта) | Открывает окно проводника проектов
Properties Window (Окно свойств) | Открывает окно свойств объектов Properties
Form Layout Window (Окно макета формы) | Открывает окно макета формы
Toolbox (Панель инструментов) | Отображает панель элементов управления
Data View Window (Окно просмотра данных) | Открывает окно просмотра данных
Color Palette (Цветовая палитра) | Отображает цветовую палитру
Toolbars (Панели инструментов) | Открывает меню, предназначенное для отображения в окне программы Visual Basic следующих панелей: Debug (Отладка), Editor (Редактор), Form Edit (Редактор форм), Standard (Стандартная панель инструментов)

к началу

Команды меню Project

Команда | Назначение
Add Form (Добавить форму) | Добавляет в окно проекта форму
Add MDI Form (Добавить форму окна MDI) | Добавляет MDI-форму
Add Module (Добавить модуль) | Добавляет программный модуль
Add Class Module (Добавить класс) | Добавляет пользовательский класс
Add User Control (Добавить элемент управления) | Добавляет пользовательский элемент управления
Add Property Page (Добавить страницу свойств) | Добавляет стандартную форму настройки свойств
Add WebClass (Добавить Web-класс) | Добавляет Web-класс
Add Data Report (Добавить отчет) | Добавляет в проект отчет
Add DHTML Page (Добавить страницу DHTML) | Добавляет страницу DHTML
Add Data Environment (Добавить среду данных) | Добавляет среду базы данных
Add File (Добавить файл) | Добавляет файл
Remove (Исключить) | Исключает файл из проекта
References (Ссылки) | Вызывает окно включения ссылок проекта на библиотеки
Components (Компоненты) | Открывает диалоговое окно Components, позволяющее добавить на панель элементов управления компоненты для их дальнейшего включения в проект приложения
Project Properties (Свойства проекта) | Открывает окно свойств проекта Project Properties

к началу

Команды меню Format

Команда | Назначение
Align (Выровнять) | Открывает меню, содержащее команды выравнивания объектов
Make Same Size (Установить подобный размер) | Открывает меню, содержащее команды, управляющие размерами объектов в форме
Horizontal Spacing (Горизонтальный интервал) | Устанавливает интервал между объектами в горизонтальном направлении
Vertical Spacing (Вертикальный интервал) | Устанавливает интервал между объектами в вертикальном направлении
Center in Form (Центрирование в форме) | Центрирует объекты в форме
Order (Порядок) | Направляет выбранный объект в нижний или верхний слой формы

к началу

Команды меню Debug

Команда | Назначение
Step Into (Шаг с заходом в процедуры) | Осуществляет пошаговое выполнение процедуры, включая также вызываемые ею процедуры
Step Over (Шаг без захода в процедуры) | Осуществляет пошаговое выполнение процедуры без трассировки вызываемых ею процедур
Step Out (Шаг с выходом из процедуры) | Выполнение программы осуществляется до выхода из текущей процедуры
Add Watch (Добавить окно Watch) | Открывает окно Add Watch (Добавить наблюдение) для ввода выражений, за значениями которых будет вестись наблюдение
Edit Watch (Открыть окно Edit Watch) | Открывает диалоговое окно Edit Watch для редактирования или удаления выражений, за значениями которых ведется наблюдение
Quick Watch (Открыть окно Quick Watch) | Открывает окно Quick Watch для просмотра значения выбранного выражения
Toggle Breakpoint (Установить точку останова) | Устанавливает точку останова
Clear All Breakpoints (Отменить все точки останова) | Удаляет все точки останова
Set Next Statement (Определить следующий оператор) | Устанавливает следующий оператор
Show Next Statement (Показать следующий оператор) | Показывает следующий оператор

к началу

Команды меню Run

Команда | Назначение
Start (Запустить) | Запускает приложение на выполнение
Start with Full Compile (Запустить с полной компиляцией) | Запускает приложение на выполнение с полной компиляцией
Break (Приостановить) | Останавливает выполнение приложения
End (Конец) | Прекращает выполнение приложения
Restart (Перезапустить) | Перезапускает приложение

к началу

Команды меню Query

Команда | Назначение
Run (Запустить) | Выполняет запрос
Clear Results (Очистить результаты) | Очищает результаты запроса
Verify SQL Syntax (Проверить синтаксис SQL) | Проверяет синтаксис запроса
Group By (Группировать) | Группирует данные в запросе
Change Type: Select (Модификация: Выбрать) | Создает запрос для выборки данных
Change Type: Insert (Модификация: Вставить) | Создает запрос, предназначенный для добавления данных в таблицу, используя значения других таблиц
Change Type: Insert Values (Модификация: Вставить значения) | Создает запрос, предназначенный для добавления данных в таблицу, используя заданные значения
Change Type: Update (Модификация: Изменить) | Создает запрос, предназначенный для изменения данных
Change Type: Delete (Модификация: Удалить) | Создает запрос, предназначенный для удаления данных
Change Type: Make Table (Модификация: Создать таблицу) | Создает новую таблицу на основе результатов выборки
Add to Output (Добавить поля) | Добавляет поля в список полей формируемой выборки
Sort Ascending (Сортировка по возрастанию) | Назначает сортировку по возрастанию
Sort Descending (Сортировка по убыванию) | Назначает сортировку по убыванию
Remove Filter (Удалить фильтр) | Удаляет фильтр
Select All Rows From <Table A > (Выбрать все записи из первой таблицы) | Создает внешнее соединение, которое выбирает все записи из первой таблицы, даже если они отсутствуют во второй таблице
Select All Rows From <ТаЫе В > (Выбрать все записи из второй таблицы) | Создает внешнее соединение, которое выбирает все записи из второй таблицы, даже если они отсутствуют в первой таблице

к началу

Команды меню Diagram

Команда | Назначение
New Text Annotation (Новый текст пояснения) | Добавляет пояснительный текст
Set Text Font (Установить шрифт) | Устанавливает шрифт
Add Related Tables (Добавить связанную таблицу) | Добавляет связанную таблицу
Show Relationship Labels (Показать связи) | Показывает наименования связей
Modify Custom View (Изменить представление) | Изменяет вид отображения таблиц в диаграмме
View Page Break (Показывает постраничную разбивку) | Показывает разбивку на страницы
Recalculate Page Break (Пересчитать постраничную разбивку) | Пересчитывает разбивку на страницы
Arrange Selection (Выравнивать выбранные) | Выравнивает выбранные таблицы
Arrange Tables (Выравнивать все таблицы) | Выравнивает все таблицы
Autosize Selected Tables (Авторазмер выделенных таблиц) | Автоматически устанавливает размер выбранных таблиц

к началу

Команды меню Tools

Команда | Назначение
Add Procedure (Добавить процедуру) | Добавляет процедуру
Procedure Attributes (Атрибуты процедуры) | Устанавливает атрибуты процедуры
Menu Editors (Редактор меню) | Вызывает окно редактора меню
Options (Параметры) | Открывает диалоговое окно Options для настройки параметров программы Visual Basic
SourseSafe (Хранилище) | Управляет хранилищем проектов

к началу

Команды меню Add-Ins

Команда | Назначение
Visual Data Manager (Менеджер баз данных) | Запускает менеджера управления базой данных
Add-In Manager (Менеджер надстроек) | Открывает диалоговое окно Add-In Manager, позволяющее добавить надстройку в Visual Basic 6

к началу

Команды меню Window

Команда | Назначение
Split (Разделить) | Разделяет окно
Tile Horizontally (Горизонтально) | Размещает окна горизонтально
Tile Vertically (Вертикально) | Размещает окна вертикально
Cascade (Каскадом) | Размещает окна каскадом
Arrange Icons (Упорядочение значков) | Изменяет размещение значков окон

к началу

Команды меню Help

Команда | Назначение
Context (Содержание) | Вызывает справочную систему с активной вкладкой Содержание
Index (Указатель) | Вызывает справочную систему с активной вкладкой Индекс
Search (Поиск) | Вызывает справочную систему с активной вкладкой Поиск
Technical Support (Техническая поддержка) | Вызывает справочную систему с информацией о службе технической поддержки Microsoft
Microsoft on the Web (Microsoft в Web) | Вызывает страницу Microsoft в Internet
About Visual Basic (0 Visual Basic) | Вызывает справочную информацию о пакете Visual Basic 6

к началу

Кнопки стандартной панели инструментов

Название (по всплывающей подсказке) | Назначение
Add Standard EXE Project (Добавить стандартный проект) | Добавляет стандартный ехе-проект
Add Form (Добавить форму) | Добавляет форму в проект
Menu Editor (Редактор меню) | Вызывает редактор меню
Open Project (Открыть проект) | Открывает проект
Save Project (Сохранить проект) | Сохраняет проект
Cut (Вырезать) | Вырезает информацию в буфер обмена
Copy (Копировать) | Копирует в буфер обмена
Paste (Вставить) | Вставляет информацию из буфера обмена
Find (Найти) | Осуществляет поиск информации по контексту
Can't Undo (Отмена предыдущего) | Отменяет предыдущее действие
Can't Redo (Отмена повторного) | Восстанавливает отмененное действие
Start (Запустить) | Запускает программу на выполнение
End (Закончить) | Прекращает выполнение программы
Break (Прервать) | Прерывает выполнение программы
Project Explorer (Проводник проекта) | Открывает окно проводника проектов
Properties Window (Окно свойств) | Открывает окно свойств
Form Layout Window (Окно макета форм) | Открывает окно макета формы
Object Browser (Браузер объектов) | Открывает окно браузера объектов
Toolbox (Панель элементов управления) | Открывает панель элементов управления
Data View Window (Окно просмотра данных) | Открывает окно просмотра данных
Visual Component Manager (Менеджер визуальных компонентов) | Открывает окно управления визуальными компонентами Visual Component Manager

к началу

Кнопки панели элементов управления

Название (по всплывающей подсказке) | Назначение
Pointer (Указатель) | Используется для позиционирования маркера (указателя) мыши
PictureBox (Графическое окно) | Размещает в форме графическое окно, предназначенное для объединения элементов в группы, для вывода в него графических изображений, а также текста, графических элементов и анимации
Label (Метка) | Размещает в форме объекты, предназначенные для создания текстовой информации, надписей и примечаний
TextBox (Текстовое поле) | Размещает в форме текстовое поле, предназначенное для ввода текстовой информации, чисел и дат
Frame (Рамка) | Создает в форме рамку с заголовком для группировки объектов в логическую группу
CommandButton (Кнопка управления) | Размещает в форме кнопки управления для инициации действий, выполнения команд, запуска программ
CheckBox (Флажок) | Размещает в форме флажок, предназначенный для формирования условий выполнения программ или каких-либо настроек, работающий по принципу "да — нет"
OptionBufrton (Переключатель) | Создает в форме переключатели для выбора режима работы или настроек выполнения программы
ComboBox (Поле со списком) | Создает в форме объект, содержащий одновременно поле ввода и раскрывающийся список
ListBox (Список) | Создает в форме список для выбора одного или нескольких значений из предлагаемого списка значений
HScrollBar (Горизонтальная полоса прокрутки) | Размещает в форме горизонтальную полосу прокрутки, используемую в качестве ползунка для выбора значения из заданного диапазона
VScrollBar (Вертикальная полоса прокрутки) | Размещает в форме вертикальную полосу прокрутки, используемую в качестве ползунка для выбора значения из заданного диапазона
Timer (Таймер) | Размещает в форме таймер
DriveListBox (Список устройств) | Создает в форме список устройств
DirListBox (Список папок) | Создает в форме древовидный список папок
FileListBox (Список файлов) | Создает в форме список файлов
Shape (Очертание) | Создает в форме геометрические фигуры, такие как прямоугольник, квадрат, круг, эллипс, прямоугольник и квадрат со скругленными углами
Line (Линия) | Создает линии
Image (Изображение) | Создает в форме поля, предназначенные для отображения графических изображений
Data (Данные) | Создает элемент управления данными в базе данных для перемещения по записям и отображения результата навигации

к началу